Курс лекций "Основы информатики"

Лекция 1" Предмет и основные понятия информатики"

Лекция 2 "Системы исчисления"

Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"

Лекция 4 "Персональный компьютер: системная плата"

Лекция 5 "Персональный компьютер: внешняя память"

Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"

Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"

Лекция 8 " Программное обеспечение"

Лекция 9 "Сжатие данных"

Лекция 10 "Компьютерные вирусы"


Лекция 1 " Предмет и основные понятия информатики"

Информатика - это комплексная, техническая наука, которая систематизирует приемы создания, сохранения, воспроизведения, обработки и передачи данных средствами вычислительной техники, а также принципы функционирования этих средств и методы управления ними. Термин "информатика" происходит от французского слова Informatique и образован из двух слов: информация и автоматика. Этот термин введен во Франции в середине 60-х лет XX ст., когда началось широкое использование вычислительной техники. Тогда в англоязычных странах вошел в употребление термин "Computer Science" для обозначения науки о преобразовании информации, которая базируется на использовании вычислительной техники. Теперь эти термины являются синонимами.

Появление информатики обусловлено возникновением и распространением новой технологии сбора, обработки и передачи информации, связанной с фиксацией данных на машинных носителях.

Предмет информатики как науки составляют:

  • аппаратное обеспечение средств вычислительной техники;
  • программное обеспечение средств вычислительной техники;
  • средства взаимодействия аппаратного и программного обеспечения;
  • средства взаимодействия человека с аппаратными и программными средствами.

Средства взаимодействия в информатике принято называть интерфейсом. Поэтому средства взаимодействия аппаратного и программного обеспечения иногда называют также программно-аппаратным интерфейсом, а средства взаимодействия человека с аппаратными и программными средствами - интерфейсом пользователя.

Основной задачей информатики как науки - это систематизация приемов и методов работы с аппаратными и программными средствами вычислительной техники. Цель систематизации состоит в том, чтобы выделять, внедрять и развивать передовые, более эффективные технологии автоматизации этапов работы с данными, а также методически обеспечивать новые технологические исследования.

Информатика - практическая наука. Ее достижения должны проходить проверку на практике и приниматься в тех случаях, если они отвечают критерию повышения эффективности. В составе основной задачи сегодня можно выделить такие основные направления информатики для практического применения :

  • архитектура вычислительных систем (приемы и методы построения систем, предназначенных для автоматической обработки данных);
  • интерфейсы вычислительных систем (приемы и методы управления аппаратным и программным обеспечением);
  • программирование (приемы, методы и средства разработки комплексных задач);
    преобразование данных (приемы и методы преобразования структур данных);
  • защита информации (обобщение приемов, разработка методов и средств защиты данных);
  • автоматизация (функционирование программно-аппаратных средств без участия человека);
  • стандартизация (обеспечение совместимости между аппаратными и программными средствами, между форматами представления данных, относящихся к разным типам вычислительных систем).

На всех этапах технического обеспечения информационных процессов для информатики ключевым вопросом есть эффективность. Для аппаратных средств под эффективностью понимают соотношение производительности оснащение к его стоимости. Для программного обеспечения под эффективностью принято понимать производительность работающих с ним пользователей. В программировании под эффективностью понимают объем программного кода, созданного программистами за единицу времени. В информатике всю жестко ориентированное на эффективность. Вопрос как осуществить ту или другую операцию, для информатики важный, но не основной. Основным есть вопрос как совершить данную операцию эффективно.

В рамках информатики, как технической науки можно сформулировать понятия информации, информационной системы и информационной технологии.

Информация

Информация - это совокупность сведений (данных), которая воспринимается из окружающей среды (входная информация), выдается в окружающую среду (исходная информация) или сохраняется внутри определенной системы.

Информация существует в виде документов, чертежей, рисунков, текстов, звуковых и световых сигналов, электрических и нервных импульсов и т.п..

Важнейшие свойства информации:

  • объективность и субъективность;
  • полнота;
  • достоверность;
  • адекватность;
  • доступность;
  • актуальность.

Данные являются составной частью информации, представляющие собой зарегистрированные сигналы.

Во время информационного процесса данные преобразовываются из одного вида в другого с помощью методов. Обработка данных включает в себя множество разных операций. Основными операциями есть:

  • сбор данных - накопление информации с целью обеспечения достаточной полноты для принятия решения;
  • формализация данных - приведение данных, которые поступают из разных источников к единой форме;
  • фильтрация данных - устранение лишних данных, которые не нужны для принятия решений;
  • сортировка данных - приведение в порядок данных за заданным признаком с целью удобства использования;
  • архивация данных - сохранение данных в удобной и доступной форме;
  • защита данных - комплекс мер, направленных на предотвращение потерь, воспроизведения и модификации данных;
  • транспортирование данных - прием и передача данных между отдаленными пользователями информационного процесса. Источник данных принят называть сервером, а потребителя - клиентом;
  • преобразование данных - преобразование данных с одной формы в другую, или с одной структуры в другую, или изменение типа носителя.

Информационная система

В информатике понятие "система" чаще используют относительно набора технических средств и программ. Системой называют также аппаратную часть компьютера. Дополнение понятия "система" словом "информационная" отображает цель ее создания и функционирования.

Информационная система - взаимосвязанная совокупность средств, методов и персонала, используемая для сохранения, обработки и выдачи информации с целью решения конкретной задачи.

Современное понимание информационной системы предусматривает использование компьютера как основного технического средства обработки информации. Компьютеры, оснащенные специализированными программными средствами, являются технической базой и инструментом информационной системы.

В работе информационной системы можно выделить слудующие этапы:

  1. Зарождение данных - формирование первичных сообщений, которые фиксируют результаты определенных операций, свойства объектов и субъектов управления, параметры процессов, содержание нормативных и юридических актов и т.п..
  2. Накопление и систематизация данных - организация такого их размещения, которое обеспечивало бы быстрый поиск и отбор нужных сведений, методическое обновление данных, защита их от искажений, потери, деформирование целостности и др.
  3. Обработка данных - процессы, вследствии которых на основании прежде накопленных данных формируются новые виды данных: обобщающие, аналитические, рекомендательные, прогнозные. Производные данные тоже можно обраббатывать, получая более обобщенные сведения.
  4. Отображение данных - представление их в форме, пригодной для восприятия человеком. Прежде всего - это вывод на печать, то есть создание документов на так называемых твердых (бумажных) носителях. Широко используют построение графических иллюстративных материалов (графиков, диаграмм) и формирование звуковых сигналов.

Сообщения, которые формируются на первом этапе, могут быть обычным бумажным документом, сообщением в "машинном виде" или тем и другим одновременно. В современных информационных системах сообщения массового характера большей частью имеют "машинный вид". Аппаратура, которая используется при этом, имеет название средства регистрации первичной информации.

Потребности второго и третьего этапов удовлетворяются в современных информационных системах в основном средствами вычислительной техники. Средства, которые обеспечивают доступность информации для человека, то есть средства отображения данных, являются компонентами вычислительной техники.

Подавляющее большинство информационных систем работает в режиме диалога с пользователем. Типичные программные компоненты информационных систем включают: диалоговую подсистему ввода-вывода, подсистему, которая реализует логику диалога, подсистему прикладной логики обработки данных, подсистему логики управления данными. Для сетевых информационных систем важным элементом является коммуникационный сервис, обеспечивающий взаимодействие узлов сети при общем решении задачи. Значительная часть функциональных возможностей информационных систем закладывается в системном программном обеспечении: операционных системах, системных библиотеках и конструкциях инструментальных средств разработки. Кроме программной составной информационных систем важную роль играет информационная составная, которая задает структуру, атрибутику и типы данных, а также тесно связана с логикой управления данными.

Информационные технологии

В широком смысле слово технология - это способ освоения человеком материального мира с помощью социально организованной деятельности, которая включает три компоненты: информационную (научные принципы и обоснование), материальную (орудие работы) и социальную (специалисты, имеющие профессиональные навыки). Эта триада составляет сущность современного понимания понятия технологии.

Понятие информационной технологии появилось с возникновением информационного общества, основой социальной динамики в котором являются не традиционные материальные, а информационные ресурсы: знания, наука, организационные факторы, интеллектуальные способности, инициатива, творчество и т.д. К сожалению, это понятие настолько общее и всеохватывающее, что до сих пор специалисты не пришли к четкой, формализованной формулироваке. Наиболее удачным определением понятия информационной технологии дано академиком Глушковым В.М., который трактовал ее как человеко-машинную технологию сбора, обработки и передачи информации, которая грунтується на использовании вычислительной техники. Эта технология быстро развивается, охватывая все виды общественной деятельности: производство, управление, науку, образование, финансово-банковские операции, медицину, быт и др.

Контрольные вопросы

  1. Что изучает наука информатика?
  2. Что понимают под интерфейсом пользователя?
  3. Что такое информация? Какими свойствами она владеет?
  4. Из каких операций складывается процесс обработки данных?
  5. Что такое информационная система?
  6. Из каких этапов складывается работа информационных систем?
  7. Какой смысл вкладывается у понятия "информационная технология"?

Список рекомендованной литературы

  1. Информатика. Компьютерная техника. Компьютерные технологии. / Пособие под ред. О.И.Пушкаря.- Издательский центр "Академия", Киев, - 2001 г.
  2. Коцюбинский А.О., Грошев С.В. Современный самоучитель профессиональной работы на компьютере. - Г.: Триумф, 1999 г.
  3. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - Спб., 2000 г.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"


Лекция 2 "Системы исчисления"

Совокупность приемов наименования и обозначение чисел называется системой исчисления. В качестве условных знаков для записи чисел используются цифры.

Система исчисления, в которой значение каждой цифры в произвольном месте последовательности цифр, обозначающей запись числа, не изменяется, называется непозиционной.

Система исчисления, в которой значение каждой цифры зависит от места в последовательности цифр в записи числа, называется позиционной.

Чтобы определить число, недостаточно знать тип и алфавит системы исчисления. Для этого необходимо еще использовать правила, которые позволяют по значениям цифр установить значение числа. Простейшим способом записи натурального числа является изображение его с помощью соответствующего количества палочек или черточек. Таким способом можно обозначить небольшие чисел. Следующим шагом было изобретение специальных символов (цифр). В непозиционной системе каждый знак в записи независимо от места означает одно и то же число. Хорошо известным примером непозиционной системы исчисления является римская система, в которой роль цифр играют буквы алфавита: І - один, V - пять, Х - десять, С - сто, L - пятьдесят, D -пятьсот, М - тысяча. Например, 324 = СССХХІ. В непозиционной системе исчисления арифметические операции выполнять неудобно и сложно.

Позиционные системы исчисления

Общепринятой в современном мире является десятичная позиционная система исчисления, которая из Индии через арабские страны пришла в Европу. Основой системы является число десять. Основой системы исчисления называется число, означающее, во сколько раз единица следующего разряда больше чем единица предыдущего.

Общеупотребительной формой записи числа является сокращенная форма записи разложения по степеням основы системы исчисления, например

130678=1*105+3*104+0*103+6*102+7*101+8

Здесь 10 служит основой системы исчисления, а показатель степени - это номер позиции цифры в записи числа (нумерация ведется слева на право, начиная с нуля). Арифметические операции в этой системе выполняют по правилам, предложенным еще в средневековье. Например, складывая два многозначных числа, применяем правило сложения столбиком. При этом все сводится к сложению однозначных чисел, для которых необходимо знать таблицу сложения.

Проблема выбора системы исчисления для представления чисел в памяти компьютера имеет большое практическое значение. В случае ее выбора обычно учитываются такие требования, как надежность представления чисел при использовании физических элементов, экономичность (использование таких систем исчисления, в которых количество элементов для представления чисел из некоторого диапазона было бы минимальном). Для изображения целых чисел от 1 до 999 в десятичной системе достаточно трех разрядов, то есть трех элементов. Поскольку каждый элемент может находиться в десяти состояниях, то общее количество состояний - 30, в двоичной системе исчисления: 99910=11111002, необходимое количество состояний - 20 (индекс внизу числа - основа системы исчисления).

Более распространенной для представления чисел в памяти компьютера является двоичная система исчисления. Для изображения чисел в этой системе необходимо две цифры: 0 и 1, то есть достаточно двух стойких состояний физических элементов. Эта система близка к оптимальной по экономичности, и кроме того, таблицы сложения и умножения в этой системе элементарные:

+ | 0 | 1 | * | 0 | 1
0 | 0 | 1 | 0 | 0 | 0
1 | 1 | 10 | 1 | 0 | 1

Поскольку 23=8, а 24=16 , то каждых три двоичных разряда числа образовывают один восьмиричный, а каждых четыре двоичных разряда - один шестнадцатиричный. Поэтому для сокращения записи адресов и содержимого оперативной памяти компьютера используют шестнадцатиричную и восьмиричную системы исчисления. Ниже, в таблице 1 приведены первые 16 натуральных чисел записанных в десятичной, двоичной, восьмиричной и шеснадцатиричной системах исчисления.

Таблица 1

10 | 2 | 8 | 16
0 | 0000 | 0 | 0
1 | 0001 | 1 | 1
2 | 0010 | 2 | 2
3 | 0011 | 3 | 3
4 | 0100 | 4 | 4
5 | 0101 | 5 | 5
6 | 0110 | 6 | 6
7 | 0111 | 7 | 7
8 | 1000 | 10 | 8
9 | 1001 | 11 | 9
10 | 1010 | 12 | A
11 | 1011 | 13 | B
12 | 1100 | 14 | C
13 | 1101 | 15 | D
14 | 1110 | 16 | E
15 | 1111 | 17 | F

Для отладки программ и в других ситуациях в программировании актуальной является проблема перевода чисел из одной позиционной системы исчисления в другую. Если основа новой системы исчисления равняется некоторой степени старой системы исчисления, то алгоритм перевода очень простой: нужно сгруппировать справа налево разряды в количестве, равном показателю степени и заменить эту группу разрядов соответствующим символом новой системы исчисления. Этим алгоритмом удобно пользоваться при переводе числа из двоичной системы исчисления в восьмиричную или шестнадцатиричную. Например, 101102=10 110=268, 10111002=101 1100=5C8

Перевод чисел из восьмиричной или шестнадцатиричной систем исчисления в двоичную происходит по обратному правилу: один символ старой системы исчисления заменяется группой разрядов новой системы исчисления, в количестве равном показателю степени новой системы исчисления. Например, 4728=100 111 010=1001110102, B516=1011 0101=101101012

Как видим, если основа одной системы исчисления равняется некоторой степени другой, то перевод очень простой. В противном случае пользуются правилами перевода числа из одной позиционной системы исчисления в другую (чаще всего при переводе из двоичной, восьмиричной и шшестнадцатиричной систем исчисления в десятичную, и наоборот).

Алгоритмы перевода чисел из одной позиционной системы исчисление в другую

1. Для перевода чисел из системы исчисления с основой p в систему исчисления с основой q, используя арифметику новой системы исчисления с основой q, нужно записать коэффициенты разложения, основы степеней и показатели степеней в системе с основой q и выполнить все действия в этой самой системе. Очевидно, что это правило удобно при переводе в десятичную систему исчисления. Например:

из шестнадцатиричной в десятичную:

92C816=9*10163+2*10162+C*10161+8*10160= 9*16103+2*16102+12*16101+8*16100=37576

из восьмиричной в десятичную:

7358=7*1082+3*1081+5*1080= 7*8102+3*8101+5*8100=47710

из двоичной в десятичную:

1101001012=1*1028+1*1027+ 0*1026+1*1025+0*1024+0*1023+ 1*1022+0*1021+1*1020= 1*2108+1*2107+0*2106+1*2105+ 0*2104+0*2103+1*2102+0*2101+ 1*2100=42110

2. Для перевода чисел из системы исчисления с основой p в систему исчисления с основой q с использованием арифметики старой системы исчисления с основой p нужно:

  • для перевода целой части:
    • последовательно число, записанное в системе основой делить на основу новой системы исчисления, выделяя остатки. Последние записанные в обратном порядке, будут образовывать число в новой системе исчисления;
  • для перевода дробной части:
    • последовательно дробную часть умножать на основу новой системы исчисления, выделяя целые части, которые и будут образовывать запись дробной части числа в новой системе исчисления.

Этим же правилом удобно пользоваться в случае перевода из десятичной системы исчисления, поскольку ее арифметика для нас привычна.

Пример: 999,3510=1111100111,010112

для целой части:

для дробной части:

Контрольные вопросы

  1. Что такое система исчисления?
  2. Какие типы систем исчисления вы знаете?
  3. Что такое основа позиционной системы исчисления?
  4. В чем состоит проблема выбора системы исчисления для представления чисел в памяти компьютера?
  5. Какая система исчисления используется для представления чисел в памяти компьютера? Почему?
  6. Каким образом осуществляется перевод чисел, если основа новой системы исчисления равняется некоторой степени старой системы исчисления?
  7. По какому правилу переводятся числа из десятичной системы исчисления

Список рекомендованной литературы

  1. Информатика. Компьютерная техника. Компьютерные технологии. / Пособие под ред. О.И.Пушкаря.- Издательский центр "Академия", Киев, - 2001 г.
  2. Коцюбинский А.О., Грошев С.В. Современный самоучитель профессиональной работы на компьютере. - Г.: Триумф, 1999 г.
  3. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - Спб., 2000 г.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"


Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"

Совокупность устройств, предназначенных для автоматической или автоматизированной обработки информации называют вычислительной техникой. Конкретный набор, связанных между собою устройств, называют вычислительной системой. Центральным устройством большинства вычислительных систем является электронная вычислительная машина (ЭВМ) или компьютер.

Архитектура компьютера

Компьютер - это электронное устройство, которое выполняет операции ввода информации, хранения и обработки ее по определенной программе, вывод полученных результатов в форме, пригодной для восприятия человеком. За любую из названных операций отвечают специальные блоки компьютера:

  • устройство ввода,
  • центральный процессор,
  • запоминающее устройство,
  • устройство вывода.

Все эти блоки состоят из отдельных меньших устройств. В частности, в центральный процессор могут входить арифметико-логическое устройство (АЛУ), внутреннее запоминающее устройство в виде регистров процессора и внутренней кэш-памяти, управляющее устройство (УУ). Устройство ввода, как правило, тоже не является одной конструктивной единицей. Поскольку виды входной информации разнообразны, источников ввода данных может быть несколько. Это касается и устройств вывода.

Схематично общая структура компьютера изображена на рис.1.

Рис. 1. Общая структура компьютера

Запоминающее устройство - это блок ЭВМ, предназначенный для временного (оперативная память) и продолжительного (постоянная память) хранения программ, входных и результирующих данных, а также промежуточных результатов. Информация в оперативной памяти сохраняется временно лишь при включенном питании, но оперативная память имеет большее быстродействие. В постоянной памяти данные могут сохраняться даже при отключенном компьютере, но скорость обмена данными между постоянной памятью и центральным процессором, в подавляющем большинстве случаев, значительно меньше.

Арифметико-логическое устройство - это блок ЭВМ, в котором происходит преобразование данных по командам программы: арифметические действия над числами, преобразование кодов и др.

Управляющее устройство координирует работу всех блоков компьютера. В определенной последовательности он выбирает из оперативной памяти команду за командой. Каждая команда декодируется, по потребности элементы данных из указанных в команде ячеек оперативной памяти передаются в АЛУ; АЛУ настраивается на выполнение действия, указанной текущей командой (в этом действии могут принимать участие также устройства ввода-вывода); дается команда на выполнение этого действия. Этот процесс будет продолжаться до тех пор, пока не возникнет одна из следующих ситуаций: исчерпаны входные данные, от одного из устройств поступила команда на прекращение работы, выключено питание компьютера.

Описанный принцип построения ЭВМ носит название архитектуры фон Неймана - американского ученого венгерского происхождения Джона фон Неймана, который ее предложил.

Современную архитектуру компьютера определяют следующие принципы:

  1. Принцип программного управления. Обеспечивает автоматизацию процесса вычислений на ЭВМ. Согласно этому принципу, для решения каждой задачи составляется программа, которая определяет последовательность действий компьютера. Эффективность программного управления будет выше при решении задачи этой же программой много раз (хотя и с разными начальными данными).
  2. Принцип программы, сохраняемой в памяти. Согласно этому принципу, команды программы подаются, как и данные, в виде чисел и обрабатываются так же, как и числа, а сама программа перед выполнением загружается в оперативную память, что ускоряет процесс ее выполнения.
  3. Принцип произвольного доступа к памяти. В соответствии с этим принципом, элементы программ и данных могут записываться в произвольное место оперативной памяти, что позволяет обратиться по любому заданному адресу (к конкретному участку памяти) без просмотра предыдущих.

На основании этих принципов можно утверждать, что современный компьютер - техническое устройство, которое после ввода в память начальных данных в виде цифровых кодов и программы их обработки, выраженной тоже цифровыми кодами, способно автоматически осуществить вычислительный процесс, заданный программой, и выдать готовые результаты решения задачи в форме, пригодной для восприятия человеком.

Реальная структура компьютера значительно сложнее, чем рассмотренная выше (ее можно назвать логической структурой). В современных компьютерах, в частности персональных, все чаще происходит отход от традиционной архитектуры фон Неймана, обусловленный стремлением разработчиков и пользователей к повышению качества и производительности компьютеров. Качество ЭВМ характеризуется многими показателями. Это и набор команд, которые компьютер способный понимать, и скорость работы (быстродействие) центрального процессора, количество периферийных устройств ввода-вывода, присоединяемых к компьютеру одновременно и т.д. Главным показателем является быстродействие - количество операций, какую процессор способен выполнить за единицу времени. На практике пользователя больше интересует производительность компьютера - показатель его эффективного быстродействия, то есть способности не просто быстро функционировать, а быстро решать конкретные поставленные задачи.

Как результат, все эти и прочие факторы способствуют принципиальному и конструктивному усовершенствованию элементной базы компьютеров, то есть созданию новых, более быстрых, надежных и удобных в работе процессоров, запоминающих устройств, устройств ввода-вывода и т.д. Тем не менее, следует учитывать, что скорость работы элементов невозможно увеличивать беспредельно (существуют современные технологические ограничения и ограничения, обусловленные физическими законами). Поэтому разработчики компьютерной техники ищут решения этой проблемы усовершенствованием архитектуры ЭВМ.

Так, появились компьютеры с многопроцессорной архитектурой, в которой несколько процессоров работают одновременно, а это означает, что производительность такого компьютера равняется сумме производительностей процессоров. В мощных компьютерах, предназначенных для сложных инженерных расчетов и систем автоматизированного проектирования (САПР), часто устанавливают два или четыре процессора. В сверхмощных ЭВМ (такие машины могут, например, моделировать ядерные реакции в режиме реального времени, прогнозировать погоду в глобальном масштабе) количество процессоров достигает нескольких десятков.

Скорость работы компьютера существенным образом зависит от быстродействия оперативной памяти. Поэтому, постоянно ведутся поиски элементов для оперативной памяти, затрачивающих меньше времени на операции чтения-записи. Но вместе с быстродействием возрастает стоимость элементов памяти, поэтому наращивание быстродействующей оперативной памяти нужной емкости не всегда приемлемо экономически.

Проблема решается построением многоуровневой памяти. Оперативная память состоит из двух-трех частей: основная часть большей емкости строится на относительно медленных (более дешевых) элементах, а дополнительная (так называемая кэш-память) состоит из быстродействующих элементов. Данные, к которым чаще всего обращается процессор находятся в кэш-памяти, а больший объем оперативной информации хранится в основной памяти.

Раньше работой устройств ввода-вывода руководил центральный процессор, что занимало немало времени. Архитектура современных компьютеров предусматривает наличие каналов прямого доступа к оперативной памяти для обмена данными с устройствами ввода-вывода без участия центрального процессора, а также передачу большинства функций управления периферийными устройствами специализированным процессорам, разгружающим центральный процессор и повышающим его производительность.

Методы классификации компьютеров

Номенклатура видов компьютеров сегодня огромная: машины различаются по назначению, мощности, размерам, элементной базе и т.д. Поэтому классифицируют ЭВМ по разным признакам. Следует заметить, что любая классификация является в некоторой мере условной, поскольку развитие компьютерной науки и техники настолько бурное, что, например, сегодняшняя микроЭВМ не уступает по мощности миниЭВМ пятилетней давности и даже суперкомпьютерам недавнего прошлого. Кроме того, зачисление компьютеров к определенному классу довольно условно через нечеткость разделения групп, так и вследствии внедрения в практику заказной сборки компьютеров, где номенклатуру узлов и конкретные модели адаптируют к требованиям заказчика. Рассмотрим распространенные критерии классификации компьютеров.

Классификация по назначению

  • большие электронно-вычислительные машины (ЭВМ);
  • миниЭВМ;
  • микроЭВМ;
  • персональные компьютеры.

Большие ЭВМ (Main Frame)

Применяют для обслуживания крупных областей народного хозяйства. Они характеризуются 64-разрядными параллельно работающими процессорами (количество которых достигает до 100), интегральным быстродействием до десятков миллиардов операций в секунду, многопользовательским режимом работы. Доминирующее положение в выпуске компьютеров такого класса занимает фирма IBM (США). Наиболее известными моделями суперЭВМ являются: IBM 360, IBM 370, IBM ES/9000, Cray 3, Cray 4, VAX-100, Hitachi, Fujitsu VP2000.

На базе больших ЭВМ создают вычислительный центр, который содержит несколько отделов или групп (структура которого изображена на рис. 2). Штат обслуживания - десятки людей.

группа технического обслуживания | центральний процессор | группа подготовки данных
группа системных программистов | отдел выдачи результатов | группа прикладных программистов
 | группа информационной поддержки |

Рис.2. Структура вычислительного центра на базе большой ЭВМ

Центральный процессор - основной блок ЭВМ, в котором происходит обработка данных и вычисление результатов. Представляет собой несколько системных блоков в отдельной комнате, где поддерживается постоянная температура и влажность воздуха.

Группа системного программирования - занимается разработкой, отладкой и внедрением программного обеспечения, необходимого для функционирования вычислительной системы. Системные программы обеспечивают взаимодействие программ с оборудованием, то есть программно-аппаратный интерфейс вычислительной системы.

Группа прикладного программирования - занимается созданием программ для выполнения конкретных действий с данными, то есть обеспечение пользовательского интерфейса вычислительной системы.

Группа подготовки данных - занимается подготовкой данных, которые будут обработаны на прикладных программах, созданных прикладными программистами. В частности, это набор текста, сканирование изображений, заполнение баз данных.

Группа технического обеспечения - занимается техническим обслуживанием всей вычислительной системы, ремонтом и отладкой аппаратуры, подсоединением новых устройств.

Группа информационного обеспечения - обеспечивает технической информацией все подразделения вычислительного центра, создает и сохраняет архивы разработанных программ (библиотеки программ) и накопленных данных (банки данных).

Отдел выдачи данных - получает данные от центрального процессора и превращает их в форму, удобную для заказчика (распечатка).

Большим ЭВМ присуща высокая стоимость оборудования и обслуживания, поэтому работа организована непрерывным циклом.

МиниЭВМ

Похожа на большие ЭВМ, но меньших размеров. Используют на крупных предприятиях, научных учреждениях и организациях. Часто используют для управления производственными процессами. Характеризуются мультипроцессорной архитектурой, подключением до 200 терминалов, дисковыми запоминающими устройствами, которые наращиваются до сотен гигабайт, разветвленной периферией. Для организации работы с миниЭВМ, нужен вычислительный центр, но меньший чем для больших ЭВМ.

МикроЭВМ

Доступны многим учреждениям. Для обслуживания достаточно вычислительной лаборатории в составе нескольких человек, с наличием прикладных программистов. Необходимые системные программы покупаются вместе с микроЭВМ, разработку прикладных программ заказывают в больших вычислительных центрах или специализированных организациях.

Программисты вычислительной лаборатории занимаются внедрением приобретенного или заказанного программного обеспечения, выполняют его настройку и согласовывают его работу с другими программами и устройствами компьютера. Могут вносить изменения в отдельные фрагменты программного и системного обеспечения.

Персональные компьютеры

Бурное развитие приобрели в последние 20 лет. Персональный компьютер (ПК) предназначен для обслуживания одного рабочего места и способен удовлетворить потребности малых предприятий и отдельных лиц. С появлением Интернета популярность ПК значительно возросла, поскольку с помощью персонального компьютера можно пользоваться научной, справочной, учебной и развлекательной информацией.
Персональные компьютеры условно можно поделить на профессиональные и бытовые, но в связи с удешевлением аппаратного обеспечения, грань между ними размывается. С 1999 года введен международный сертификационный стандарт - спецификация РС99:

  • массовый персональный компьютер (Consumer PC)
  • деловой персональный компьютер (Office PC)
  • портативный персональный компьютер (Mobile PC)
  • рабочая станция (WorkStation)
  • развлекательный персональный компьютер (Entertaiment PC)

Большинство персональных компьютеров на рынке подпадают до категории массовых ПК. Деловые ПК - имеют минимум средств воспроизведения графики и звука. Портативные ПК отличаются наличием средств коммуникации отдаленного доступа (компьютерная связь). Рабочие станции - увеличенные требования к устройствам хранения данных. Развлекательные ПК - основной акцент на средствах воспроизведения графики и звука.

Классификация по уровню специализации

  • универсальные;
  • специализированные.

На базе универсальных ПК можно создать любую конфигурацию для работы с графикой, текстом, музыкой, видео и т.п.. Специализированные ПК созданы для решения конкретных задач, в частности, бортовые компьютеры в самолетах и автомобилях. Специализированные миниЭВМ для работы с графикой (кино- видеофильмы, реклама) называются графическими станциями. Специализированные компьютеры, объединяющие компьютеры в единую сеть, называются файловыми серверами. Компьютеры, обеспечивающие передачу информации через Интернет, называются сетевыми серверами.

Классификация по размеру

  • настольные (desktop);
  • портативные (notebook);
  • карманные (palmtop).

Наиболее распространенными являются настольные ПК, которые позволяют легко изменять конфигурацию. Портативные удобны для пользования, имеют средства компьютерной связи. Карманные модели можно назвать "интеллектуальными" записными книжками, разрешают хранить оперативные данные и получать к ним быстрый доступ.

Классификация по совместимости

Существует великое множество типов компьютеров, которые собираются из деталей, изготовленных разными производителями. Важным является совместимость обеспечения компьютера:

  • аппаратная совместимость (платформа IBM PC и Apple Macintosh)
  • совместимость на уровне операционной системы;
  • программная совместимость;
  • совместимость на уровне данных.

Контрольные вопросы

  1. Что такое архитектура компьютера? Общая структура компьютера?
  2. Принципы современной архитектуры компьютера?
  3. Методы классификации компьютеров? Классификация по назначению?
  4. Большие ЭВМ (Main Frame)? Структура вычислительного центра на базе большой ЭВМ?
  5. МиниЭВМ? МикроЭВМ?
  6. Персональные компьютеры? Классификация по международному сертификационному стандарту?
  7. Классификация по уровню специализации? Классификация по размеру? Классификация по совместимости?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"


Лекция 4 "Персональный компьютер: системная плата"

Компьютер - это универсальная техническая система, способная четко выполнять последовательность операций определенной программы. Персональным компьютером (ПК) может пользоваться один человек без помощи обслуживающего персонала. Взаимодействие с пользователем происходит через много сред, от алфавитно-цифрового или графического диалога с помощью дисплея, клавиатуры и мышки до устройств виртуальной реальности.

Конфигурацию ПК можно изменять по мере необходимости. Но, существует понятие базовой конфигурации, которую можно считать типичной:

  • системный блок;
  • монитор;
  • клавиатура;
  • мышка.

Компьютеры выпускаются и в портативном варианте (laptop или notebook выполнение). В этом случае, системный блок, монитор и клавиатура размещены в одном корпусе: системный блок находится под клавиатурой, а монитор встроен в крышку.

Системный блок - основная составляющая ПК, в середине которой находятся важнейшие компоненты. Устройства, находящиеся в середине системного блока называют внутренними, а устройства, подсоединенные извне называют внешними. Внешние дополнительные устройства, предназначенные для ввода и вывода информации называются также периферийными.

По внешнему виду, системные блоки отличаются формой корпуса, который может быть горизонтального (desktop) или вертикального (tower) выполнение. Корпусы вертикального выполнения могут иметь разные размеры: полноразмерный (BigTower), среднеразмерный (MidiTower), малоразмерный (MiniTower). Корпусы горизонтального выполнения бывают двух форматов: узкий (Full-AT) и очень узкий (Baby-AT). Корпусы персональных компьютеров имеют разные конструкторские особенности и дополнительные элементы (элементы блокировки несанкционированного доступа, средства контроля внутренней температуры, шторки от пыли).

Корпусы поставляются вместе с блоком питания, мощность которого является одним из параметров корпуса. Для массовых моделей достаточной является мощность 200-250 Вт.

Основные узлы системного блока:

  • электрические платы, руководящие работой компьютера (микропроцессор, оперативная память, контроллеры устройств и т.п.);
  • накопитель на жестком диске (винчестер), предназначенный для чтения или записи информации;
  • накопители (дисководы) для гибких магнитных дисков (дискет).

Основной платой ПК является материнская плата (MotherBoard). На ней расположенны:

  • процессор - основная микросхема, выполняющая математические и логические операции;
  • чипсет (микропроцессорный комплект) - набор микросхем, которые руководят работой внутренних устройств ПК и определяют основные функциональные возможности материнской платы;
  • шины - набор проводников, по которым происходит обмен сигналами между внутренними устройствами компьютера;
  • оперативное запоминающее устройство (ОЗУ) - набор микросхем, предназначенных для временного сохранения данных, пока включен компьютер;
  • постоянное запоминающее устройство (ПЗУ) - микросхема, предназначенная для долговременного хранения данных, даже при отключенном компьютере;
  • разъемы для подсоединения дополнительных устройств (слоты).

Процессор

Процессор - это главная микросхема компьютера, его "мозг". Он разрешает выполнять программный код, находящийся в памяти и руководит работой всех устройств компьютера. Скорость его работы определяет быстродействие компьютера. Конструктивно, процессор - это кристалл кремния очень маленьких размеров. Процессор имеет специальные ячейки, которые называются регистрами. Именно в регистрах помещаются команды, которые выполняются процессором, а также данные, которыми оперируют команды. Работа процессора состоит в выборе из памяти в определенной последовательности команд и данных и их выполнении. На этом и базируется выполнение программ.

В ПК обязательно должен присутствовать центральный процессор (Central Rpocessing Unit - CPU), который выполняет все основные операции. Часто ПК оснащен дополнительными сопроцесорами, ориентированными на эффективное выполнение специфических функций, такие как, математический сопроцесор для обработки числовых данных в формате с плавающей точкой, графический сопроцесор для обработки графических изображений, сопроцесор ввода/вывода для выполнения операции взаимодействия с периферийными устройствами.

Основными параметрами процессоров являются:

  • тактовая частота,
  • разрядность,
  • рабочее напряжение,
  • коэффициент внутреннего умножения тактовой частоты,
  • размер кеш памяти.

Тактовая частота определяет количество элементарных операций (тактов), выполняемые процессором за единицу времени. Тактовая частота современных процессоров измеряется в МГц (1 Гц соответствует выполнению одной операции за одну секунду, 1 МГц=106 Гц). Чем больше тактовая частота, тем больше команд может выполнить процессор, и тем больше его производительность. Первые процессоры, которые использовались в ПК работали на частоте 4,77 МГц, сегодня рабочие частоты современных процессоров достигают отметки в 2 ГГц (1 ГГц = 103 МГц).

Разрядность процессора показывает, сколько бит данных он может принять и обработать в своих регистрах за один такт. Разрядность процессора определяется разрядностью командной шины, то есть количеством проводников в шине, по которой передаются команды. Современные процессоры семейства Intel являются 32-разрядными.

Рабочее напряжение процессора обеспечивается материнской платой, поэтому разным маркам процессоров отвечают разные материнские платы. Рабочее напряжение процессоров не превышает 3 В. Снижение рабочего напряжения разрешает уменьшить размеры процессоров, а также уменьшить тепловыделение в процессоре, что разрешает увеличить его производительность без угрозы перегрева.

Коэффициент внутреннего умножения тактовой частоты - это коэффициент, на который следует умножить тактовую частоту материнской платы, для достижения частоты процессора. Тактовые сигналы процессор получает от материнской платы, которая из чисто физических причин не может работать на таких высоких частотах, как процессор. На сегодня тактовая частота материнских плат составляет 100-133 Мгц. Для получения более высоких частот в процессоре происходит внутреннее умножение на коэффициент 4, 4.5, 5 и больше.

Кэш-память. Обмен данными внутри процессора происходит намного быстрее, чем обмен данными между процессором и оперативной памятью. Поэтому, для того чтобы уменьшить количество обращений к оперативной памяти, внутри процессора создают так называемую сверхоперативную или кэш-память. Когда процессору нужны данные, он сначала обращается к кэш-памяти, и только тогда, когда там отсутствуют нужные данные, происходит обращение к оперативной памяти. Чем больше размер кэш-памяти, тем большая вероятность, что необходимые данные находятся там. Поэтому высокопроизводительные процессоры имеют повышенные объемы кэш-памяти.

Различают кэш-память первого уровня (выполняется на одном кристалле с процессором и имеет объем порядка несколько десятков Кбайт), второго уровня (выполняется на отдельном кристалле, но в границах процессора, с объемом в сто и более Кбайт) и третьего уровня (выполняется на отдельных быстродействующих микросхемах с расположением на материнской плате и имеет объем один и больше Мбайт).

В процессе работы процессор обрабатывает данные, находящиеся в его регистрах, оперативной памяти и внешних портах процессора. Часть данных интерпретируется как собственно данные, часть данных - как адресные данные, а часть - как команды. Совокупность разнообразных команд, которые может выполнить процессор над данными, образовывает систему команд процессора. Чем больше набор команд процессора, тем сложнее его архитектура, тем длиннее запись команд в байтах и тем дольше средняя продолжительность выполнения команд.

Процессоры Intel, используемые в IBM-совместных ПК, насчитывают более тысячи команд и относятся к процессорам с расширенной системой команд - CISC-процессоров (CISC - Complex Instruction Set Computing). В противоположность CISC-процессорам разработаны процессоры архитектуры RISC с сокращенной системой команд (RISC - Reduced Instruction Set Computing). При такой архитектуре количество команд намного меньше, и каждая команда выполняется быстрее. Таким образом, программы, состоящие из простых команд выполняются намного быстрее на RISC-процессорах. Обратная сторона сокращенной системы команд состоит в том, что сложные операции приходится эмулировать далеко не всегда эффективной последовательностью более простых команд. Поэтому CISC-процессоры используются в универсальных компьютерных системах, а RISC-процессоры - в специализированных. Для ПК платформы IBM PC доминирующими являются CISC-процессоры фирмы Intel, хотя в последнее время компания AMD изготовляет процессоры семейства AMD-K6, которые имеют гибридную архитектуру (внутреннее ядро этих процессоров выполненное по RISC-архитектуре, а внешняя структура - по архитектуре CISC).

В компьютерах IBM PC используют процессоры, разработанные фирмой Intel, или совместимые с ними процессоры других фирм, относящиеся к семейству x86. Родоначальником этого семейства был 16-разрядный процессор Intel 8086. В дальнейшем выпускались процессоры Intel 80286, Intel 80386, Intel 80486 с модификациями, разные модели Intel Pentium, Pentium MMX, Pentium Pro, Pentium II, Celeron, Pentium III. Новейшей моделью фирмы Intel является процессор Pentium IV. Среди других фирм-производителей процессоров следует отметить AMD с моделями AMD-K6, Athlon, Duron и Cyrix.

Шины

С другими устройствами, и в первую очередь с оперативной памятью, процессор связан группами проводников, которые называются шинами. Основных шин три:

  • шина данных,
  • адресная шина,
  • командная шина.

Адресная шина. Данные, которые передаются по этой шине трактуются как адреса ячеек оперативной памяти. Именно из этой шины процессор считывает адреса команд, которые необходимо выполнить, а также данные, с которыми оперируют команды. В современных процессорах адресная шина 32-разрядная, то есть она состоит из 32 параллельных проводников.

Шина данных. По этой шине происходит копирование данных из оперативной памяти в регистры процессора и наоборот. В ПК на базе процессоров Intel Pentium шина данных 64-разрядная. Это означает, что за один такт на обработку поступает сразу 8 байт данных.

Командная шина. По этой шине из оперативной памяти поступают команды, выполняемые процессором. Команды представлены в виде байтов. Простые команды вкладываются в один байт, но есть и такие команды, для которых нужно два, три и больше байта. Большинство современных процессоров имеют 32-разрядную командную шину, хотя существуют 64-разрядные процессоры с командной шиной.

Шины на материнской плате используются не только для связи с процессором. Все другие внутренние устройства материнской платы, а также устройства, которые подключаются к ней, взаимодействуют между собой с помощью шин. От архитектуры этих элементов во многом зависит производительность ПК в целом.

Основные шинные интерфейсы материнских плат:

ISA (Industry Standard Architecture). Разрешает связать между собой все устройства системного блока, а также обеспечивает простое подключение новых устройств через стандартные слоты. Пропускная способность составляет до 5,5 Мбайт/с. В современных компьютерах может использоваться лишь для подсоединения внешних устройств, которые не требуют большей пропускной способности (звуковые карты, модемы и т.д.).

EISA (Extended ISA). Расширение стандарта ISA. Пропускная способность возросла до 32 Мбайт/с. Как и стандарт ISA, этот стандарт исчерпал свои возможности и в будущем выпуск плат, которые поддерживают эти интерфейсы прекратится.

VLB (VESA Local Bus). Интерфейс локальной шины стандарта VESA. Локальная шина соединяет процессор с оперативной памятью в обход основной шины. Она работает на большей частоте, чем основная шина, и позволяет увеличить скорость передачи данных. Позже, в локальную шину "врезали" интерфейс для подключения видеоадаптера, который требует повышенной пропускной способности, что и привело к появлению стандарта VLB. Пропускная способность - до 130 Мбайт/с, рабочая тактовая частота - 50 МГц, но она зависит от количества устройств, подсоединенных к шине, что является главным недостатком интерфейса VLB.

PCI (Peripherial Component Interconnect). Стандарт подключения внешних устройств, введенный в ПК на базе процессора Pentium. По своей сути, это интерфейс локальной шины с разъемами для подсоединения внешних компонентов. Данный интерфейс поддерживает частоту шины до 66 МГц и обеспечивает быстродействие до 264 Мбайт/с независимо от количества подсоединенных устройств. Важным нововведением этого стандарта является поддержка механизма plug-and-play, суть которого состоит в том, что после физического подключения внешнего устройства к разъему шины PCI происходит автоматическая конфигурация этого устройства.

FSB (Front Side Bus). Начиная с процессора Pentium Pro для связи с оперативной памятью используется специальная шина FSB. Эта шина работает на частоте 100-133 МГц и имеет пропускную способность до 800 Мбайт/с. Частота шины FSB является основным параметром, именно она указывается в спецификации материнской платы. За шиной PCI осталась лишь функция подключения новых внешних устройств.

AGP (Advanced Graphic Port). Специальный шинный интерфейс для подключения видеоадаптеров. Разработан в связи с тем, что параметры шины PCI не отвечают требованиям видеоадаптеров по быстродействию. Частота этой шины - 33 или 66 МГц, пропускная способность до 1066 Мбайт/с.

USB (Universal Serial Bus). Стандарт универсальной последовательной шины определяет новый способ взаимодействия компьютера с периферийным оборудованием. Он разрешает подключать до 256 разных устройств с последовательным интерфейсом, причем устройства могут подсоединяться цепочкой. Производительность шины USB относительно небольшая и составляет 1,55 Мбит/с. Среди преимуществ этого стандарта следует отметить возможность подключать и отключать устройства в "горячем режиме" (то есть без перезагрузки компьютера), а также возможность объединения нескольких компьютеров в простую сеть без использования специального аппаратного и программного обеспечения.

Внутренняя память

Под внутренней памятью понимают все виды запоминающих устройств, расположенные на материнской плате. К ним относятся оперативная память, постоянная память и энергонезависимая память.

Оперативная память RAM (Random Access Memory)

Память RAM - это массив кристаллических ячеек, способных сохранять данные. Она используется для оперативного обмена информацией (командами и данными) между процессором, внешней памятью и периферийными системами. Из нее процессор берет программы и данные для обработки, в нее записываются полученные результаты. Название "оперативная" происходит от того, что она работает очень быстро и процессору не нужно ждать при считывании данных из памяти или записи. Однако, данные сохраняются лишь временно при включенном компьютере, иначе они исчезают.

По физическому принципу действия различают динамическую память DRAM и статическую память SRAM.
Ячейки динамической памяти можно представить в виде микроконденсаторов, способных накапливать электрический заряд. Недостатки памяти DRAM: медленнее происходит запись и чтение данных, требует постоянной подзарядки. Преимущества: простота реализации и низкая стоимость.

Ячейки статической памяти можно представить как электронные микроэлементы - триггеры, состоящие из транзисторов. В триггере сохраняется не заряд, а состояние (включенный/выключенный). Преимущества памяти SRAM: значительно большее быстродействие. Недостатки: технологически более сложный процесс изготовления, и соответственно, большая стоимость.

Микросхемы динамической памяти используются как основная оперативная память, а микросхемы статической - для кэш-памяти.

Каждая ячейка памяти имеет свой адрес, выраженный числом. В современных ПК на базе процессоров Intel Pentuim используется 32-разрядная адресация. Это означает, что всего независимых адресов есть 232, то есть возможное адресное пространство составляет 4,3 Гбайт. Однако, это еще не означает, что именно столько оперативной памяти может быть в системе. Предельный размер объема памяти определяется чипсетом материнской платы и обычно составляет несколько сотен мегабайт.

Оперативная память в компьютере размещена на стандартных панельках, которые называются модулями. Модули оперативной памяти вставляют в соответствующие разъемы на материнской плате. Конструктивно модули памяти имеют два выполнения - однорядные (SIMM - модули) и двурядные (DIMM - модули). На компьютерах с процессорами Pentium однорядные модули можно применять лишь парами (количество разъемов для их установления на материнской плате всегда четное). DIMM - модули можно устанавливать по одному. Комбинировать на одной плате разные модули нельзя.

Основные характеристики модулей оперативной памяти:

  • объем памяти,
  • время доступа.

SIMM - модули имеют объем 4, 8, 16, 32, 64 мегабайт; DIMM - модули - 16, 32, 64, 128, 256, 512 Мбайт. Время доступа показывает, сколько времени необходимо для обращения к ячейкам памяти, чем меньше, тем лучше. Измеряется в наносекундах. SIMM - модули - 50-70 нс, DIMM - модули - 7-10 нс.

Постоянная память ROM (Read Only Memory)

В момент включения компьютера в его оперативной памяти отсутствуют любые данные, поскольку оперативная память не может сохранять данные при отключенном компьютере. Но процессору необходимы команды, в том числе и сразу после включения. Поэтому процесор обращается по специальному стартовому адресу, который ему всегда известен, за своей первой командой. Этот адрес указывает на память, которую принято называть постоянной памятью ROM или постоянным запоминающим устройством (ПЗУ). Микросхема ПЗУ способна продолжительное время сохранять информацию, даже при отключенном компьютере. Говорят, что программы, которые находятся в ПЗУ, "зашиты" в ней - они записываются туда на этапе изготовления микросхемы. Комплект программ, находящийся в ПЗУ образовывает базовую систему ввода/вывода BIOS (Basic Input Output System).

Основное назначение этих программ состоит в том, чтобы проверить состав и трудоспособность системы и обеспечить взаимодействие с клавиатурой, монитором, жесткими и гибкими дисками.

Энергонезависимая память CMOS

Работа таких стандартных устройств, как клавиатура, может обслуживаться программами BIOS, но такими средствами невозможно обеспечить роботу со всеми возможными устройствами (в связи с их огромным разнообразием и наличием большого количества разных параметров). Но для своей работы программы BIOS требуют всю информацию о текущей конфигурации системы. По очевидной причине эту информацию нельзя сохранять ни в оперативной памяти, ни в постоянной. Специально для этих целей на материнской плате есть микросхема энергонезависимой памяти, которая называется CMOS. От оперативной памяти она отличается тем, что ее содержимое не исчезает при отключении компьютера, а от постоянной памяти она отличается тем, что данные можно заносить туда и изменять самостоятельно, в соответствии с тем, какое оборудование входит в состав системы.

Микросхема памяти CMOS постоянно питается от небольшой батарейки, расположенной на материнской плате. В этой памяти сохраняются данные про гибкие и жесткие диски, процессоры и т.д. Тот факт, что компьютер четко отслеживает дату и время, также связанн с тем, что эта информация постоянно хранится (и обновляется) в памяти CMOS. Таким образом, программы BIOS считывают данные о составе компьютерной системы из микросхемы CMOS, после чего они могут осуществлять обращение к жесткому диску и другим устройствам.

Контрольные вопросы

  1. Что такое материнская плата? Какие компоненты персонального компьютера на ней находятся?
  2. В чем состоит выполнение программ центральным процессором?
  3. Какие основные параметры процессора? Что характеризует тактовая частота и в каких единицах она измеряется?
  4. Что такое кэш-память? Уровни кэш-памяти?
  5. Для чего предназначенны шины? Какие есть типы шин?
  6. Какие шинные интерфейсы материнской платы вы знаете?
  7. Чем отличается оперативная память от постоянной памяти?
  8. Что такое RISC-процессоры? В чем состоит их отличие от CISC-процессоров?
  9. В какой памяти сохраняются программы BIOS?
  10. Какая информация сохраняется в энергонезависимой памяти?
  11. Какие вы знаете типы оперативной памяти? Какая между ними разница?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"


Лекция 5 "Персональный компьютер: внешняя память"

Внешняя память - это память, реализованная в виде внешних, относительно материнской платы, устройств с разными принципами хранения информации и типами носителя, предназначенных для долговременного хранения информации. В частности, в внешней памяти хранится все программное обеспечение компьютера. Устройства внешней памяти могут размещаться как в системном блоке компьютера, так и в отдельных корпусах. Физически, внешняя память реализована в виде накопителей. Накопители - это запоминающие устройства, предназначенные для продолжительного (что не зависит от электропитания) хранения больших объемов информации. Емкость накопителей в сотни раз превышает емкость оперативной памяти или вообще неограниченная, когда речь идет о накопителях со сменными носителями.

Накопитель можно рассматривать как совокупность носителя и соответствующего привода. Различают накопители с сменными и постоянными носителями. Привод - это объединение механизма чтения-записи с соответствующими электронными схемами управления. Его конструкция определяется принципом действия и видом носителя. Носитель - это физическая среда хранения информации, по внешнему виду может быть дисковым или ленточным. По принципу запоминания различают магнитные, оптические и магнитооптичческие носители. Ленточные носители могут быть лишь магнитными, в дисковых носителях используют магнитные, магнитооптические и оптические методы записи-считывания информации.

Самыми распространенными являются накопители на магнитных дисках, которые делятся на накопители на жестких магнитных дисках (НЖМД) и накопители на гибких магнитных дисках (НГМД), и накопители на оптических дисках, такие как накопители CD-ROM, CD-R, CD-RW и DVD-ROM.

Накопители на жестких магнитных дисках (НЖМД)

НЖМД - это основное устройство для долговременного хранения больших объемов данных и программ. Другие названия: жесткий диск, винчестер, HDD (Hard Disk Drive). Внешне, винчестер представляет собой плоскую, герметически закрытую коробку, внутри которой находятся на общей оси находятся несколько жестких алюминиевых или стеклянных пластинок круглой формы. Поверхность любого из дисков покрыта тонким ферромагнитным слоем (вещество, которое реагирует на внешнее магнитное поле), собственно на нем хранятся записанные данные. При этом запись проводится на обе поверхности каждой пластины (кроме крайних) с помощью блока специальных магнитных головок. Каждая головка находится над рабочей поверхностью диска на расстоянии 0,5-0,13 мкм. Пакет дисков вращается непрерывно и с большой частотой (4500-10000 об/мин), поэтому механический контакт головок и дисков недопустим.

Запись данных в жестком диске осуществляется следующим образом. При изменении силы тока, проходящего через головку, происходит изменение напряженности динамического магнитного поля в щели между поверхностью и головкой, что приводит к изменению стационарного магнитного поля ферромагнитных частей покрытия диска. Операция считывания происходит в обратном порядке. Намагниченные частички ферромагнитного покрытия являются причиной электродвижущей силы самоиндукции магнитной головки. Электромагнитные сигналы, которые возникают при этом, усиливаются и передаются на обработку.
Работой винчестера руководит специальное аппаратно-логическое устройство - контроллер жесткого диска. В прошлом это была отдельная дочерняя плата, которую подсоединяли через слоты к материнской плате. В современных компьютерах функции контроллера жесткого диска выполняют специальные микросхемы, расположенные в чипсете.

В накопителе может быть до десяти дисков. Их поверхность разбивается на круги, которые называются дорожками (track). Каждая дорожка имеет свой номер. Дорожки с одинаковыми номерами, расположенные одна над другой на разных дисках образуют цилиндр. Дорожки на диске разбиты на секторы (нумерация начинается с единицы). Сектор занимает 571 байт: 512 отведено для записи нужной информации, остальные под заголовок (префикс), определяющий начало и номер секции и окончание (суффикс), где записана контрольная сумма, нужная для проверки целостности хранимых данных. Секторы и дорожки образуются во время форматирования диска. Форматирование выполняет пользователь с помощью специальных программ. На неформатированный диск не может быть записана никакая информация. Жесткий диск можно разбить на логические диски. Это удобно, поскольку наличие нескольких логических дисков упрощает структуризацию данных, хранящихся на жестком диске.

Существует огромное количество разных моделей жестких дисков многих фирм, таких как Seagate, Maxtor, Quantum, Fujitsu и т.д. Для обеспечения совместимости винчестеров, разработаны стандарты на их характеристики, определяющие номенклатуру соединительных проводников, их размещение в переходных разъемах, электрические параметры сигналов. Распространенными являются стандарты интерфейсов IDE (Integrated Drive Electronics) или ATA и более продуктивные EIDE (Enhanced IDE) и SCSI (Small Computer System Interface). Характеристики интерфейсов, с помощью которых винчестеры связаны с материнской платой, в значительной степени определяют производительность современных жестких дисков.

Среди других параметров, которые влияют на быстродействие HDD следует отметить следующие:

  • скорость обращения дисков - в наше время выпускаются накопители EIDE с частотой обращения 4500-7200 об/мин, и накопители SCSI - 7500-10000 об/мин;
  • емкость кэш-памяти - во всех современных дисковых накопителях устанавливается кэш-буфер, ускоряющий обмен данными; чем больше его емкость, тем выше вероятность того, что в кэш-памяти будет необходимая информация, которую не надо считывать с диска (этот процесс в тысячи раз медленней); емкость кэш-буфера в разных устройствах может изменяться в границах от 64 Кбайт до 2Мбайт;
  • среднее время доступа - время (в миллисекундах), на протяжении которого блок головок смещается с одного цилиндра на другой. Зависит от конструкции привода головок и составляет приблизительно 10-13 миллисекунд;
  • время задержки - это время от момента позиционирования блока головок на нужный цилиндр до позицирования конкретной головки на конкретный сектор, другими словами, это время поиска нужного сектора;
  • скорость обмена - определяет объемы данных, которые могут быть переданы из накопителя к микропроцессору и в обратном направлении за определенные промежутки времени; максимальное значение этого параметра равно пропускной способности дискового интерфейса и зависит от того, какой режим используется: PIO или DMA; в режиме PIO обмен данными между диском и контроллером происходит при непосредственном участии центрального процессора, чем больше номер режима PIO, тем выше скорость обмена; работа в режиме DMA (Direct Memory Access) разрешает передавать данные непосредственно в оперативную память без участия процессора; скорость передачи данных в современных жестких дисках колеблется в диапазоне 30-60 Мбайт/с.

Накопители на гибких магнитных дисках (НГМД)

НГМД или дисковод вмонтирован в системный блок. Гибкие носители для НГМД выпускают в виде дискет (другое название флоппи-диск). Собственно, носитель - это плоский диск со специальной, достаточно плотной пленкой, покрытой ферромагнитным слоем и помещенной в защитный конверт с подвижной задвижкой в верхней части. Дискеты используются, в основном, для оперативного переноса небольших объемов информации с одного компьютера на другой. Данные, записанные на дискете можно защитить от стирания или перезаписи. Для этого нужно передвинуть маленькую защитную задвижку в нижней части дискеты таким образом, чтобы образовалось открытое окошко. Для того, чтобы разрешить запись, эту задвижку следует переместить назад и закрыть окошко.

Лицевая панель дисковода выведена на переднюю панель системного блока, на ней расположены карман, закрытый шторкой, куда вставляют дискету, кнопка для вынимания дискеты и лампочка-индикатор. Дискета вставляется в дисковод верхней задвижкой вперед, ее нужно вставить в карман накопителя и плавно продвинуть вперед до щелчка. Правильное направление вставления дискеты помечено стрелкой на пластиковом корпусе. Чтобы вынуть дискету из накопителя, нужно нажать на его кнопку. Световой индикатор на дисководе показывает, что устройство занято (если лампочка горит, вынимать дискету не рекомендуется). В отличие от жесткого диска, диск в НГМД приводится во вращение только при команде чтения или записи, в другое время он находится в покое. Головка чтения-записи во время работы механически контактирует с поверхностью дискеты, что приводит к быстрому изнашиванию дискет.

Как и в случае жесткого диска, поверхность гибкого диска разбивается на дорожки, которые в свою очередь разбиваются на секторы. Секторы и дорожки получаются во время форматирования дискеты. Сейчас дискеты поставляются отформатироваными.

Основными параметрами дискеты является технологический размер (в дюймах), плотность записи и полная емкость. По размерам различают 3,5-дюймовые дискеты и 5,25-дюймовые дискеты (сейчас уже не используются). Плотность записи может быть простой SD (Single Density), двойной DD (Double Density) и высокой HD (High Density). Стандартная емкость 3,5-дюймовой дискеты - 1,44 Мбайт, возможно использование дискет емкостью 720 Кбайт. В настоящее время стандартом являются дискеты размером 3,5 дюйма, высокой плотности HD, имеющие емкость 1,44 Мбайта.

Во время пользования дискетой следует придерживаться таких правил:

  • не касаться рабочей поверхности дискеты;
  • не выгибать дискету;
  • не снимать металлическую задвижку, загрязненная дискета может повредить головки ;
  • сохранять дискеты подальше от источника магнитных полей;
  • перед использованием проверить дискету на наличие вирусов с помощью антивирусной программы.

Накопители на оптических дисках

Накопитель CD-ROM

Начиная с 1995 года в базовую конфи-гурацию персонального компьютера вместо дисководов на 5,25 дюймов начали включать дисковод CD-ROM. Аббревиатура CD-ROM (Compact Disk Read Only Memory) переводится как постоянное запоминающее устройство на основе компакт-дисков. Принцип действия этого устройства состоит в считывании цифровых данных с помощью лазерного луча, который отражается от поверхности диска. В качестве носителя информации используется обычный компакт-диск CD. Цифровая запись на компакт-диск отличается от записи на магнитные диски высокой плотностью, поэтому стандартный CD имеет емкость порядка 650-700 Мбайт. Такие большие объемы характерны для мультимедийной информации (графика, музыка, видео), поэтому дисководы CD-ROM относятся к аппаратным средствам мультимедиа. Кроме мультимедийних изданий (электронные книги, энциклопедии, музыкальные альбомы, видеофильмы, компьютерные игры) на компакт-дисках распространяется разнообразное системное и прикладное программное обеспечения больших объемов (операционные системи, офисные пакеты, системы программирования и т.д.)

Компакт-диски изготовляют из прозрачного пластика диаметром 120 мм. и толщиной 1,2 мм. На пластиковую поверхность напыляется слой алюминия или золота. В условиях массового производства запись информации на диск происходит путем выдавливания на поверхности дорожки, в виде ряда углублений. Такой подход обеспечивает двоичную запись информации. Углубление (pit - пит), поверхность (land - лэнд). Логический нуль может быть представлен как питом, так и лэндом. Логическая единица кодируется переходом между питом и лэндом. От центра к краю компакт-диска нанесена единственная дорожка в виде спирали шириной 4 микрона с шагом 1,4 микрона. Поверхность диска разбита на три области. Начальная (Lead-In) расположена в центре диска и считывается первой. В ней записано содержимое диска, таблица адресов всех записей, метка диска и другая служебная информация. Средняя область содержит основную информацию и занимает большую часть диска. Конечная область (Lead-Out) содержит метку конца диска.

Для штамповки существует специальная матрица-прототип (мастер-диск) будущего диска, которая выдавливает дорожки на поверхности. После штамповки, на поверхность диска наносят защитную пленку из прозрачного лака.

Накопитель CD-ROM содержит:

  • электродвигатель, который вращает диск;
  • оптическую систему, состоящую из лазерного излучателя, оптических линз и датчиков и предназначенную для считывания информации с поверхности диска;
  • микропроцессор, который руководит механикой привода, оптической системой и декодирует прочитанную информацию в двоичный код.

Компакт-диск раскручивается электродвигателем. На поверхность диска с помощью привода оптической системы фокусируется луч из лазерного излучателя. Луч отражается от поверхности диска и сквозь призму подается на датчик. Световой поток превращается в электрический сигнал, который поступает в микропроцессор, где он анализируется и превращается в двоичный код.

Основные характеристики CD-ROM:

  • скорость передачи данных - измеряется в кратных долях скорости проигрывателя аудио компакт-дисков (150 Кбайт/сек) и характеризует максимальную скорость с которой накопитель пересылает данные в оперативную память компьютера, например, 2-скоростной CD-ROM (2x CD-ROM) будет считывать данные с скоростью 300 Кбайт/сек., 50-скоростной (50x) - 7500 Кбайт/сек.;
  • время доступа - время, нужное для поиска информации на диске, измеряется в миллисекундах.

Основной недостаток стандартных CD-ROM - невозможность записывания данных, но существуют устройства однократной записи CD-R и многоразовой записи CD-RW.

Накопитель CD-R (CD-Recordable)

Внешне похожи на накопители CD-ROM и совместимые с ними по размерам дисков и форматам записи. Позволяют выполнить одноразовую запись и неограниченное количество считываний. Запись данных осуществляется с помощью специального программного обеспечения. Скорость записи современных накопителей CD-R составляет 4х-8х.

Накопитель CD-RW (CD-ReWritable)

Используются для многоразовой записи данных, причем можно как просто дописать новую информацию на свободное пространство, так и полностью перезаписать диск новой информацией (предудущие данные уничтожаются). Как и в случае с накопителями CD-R, для записи данных необходимо установить в системе специальные программы, причем формат записи совместимый с обычным CD-ROM. Скорость записи современных накопителей CD-RW составляет 2х-4х.

Накопитель DVD (Digital Video Disk)

Устройство для чтения цифровых видеозаписей. Внешне DVD-диск похож на обычный CD-ROM (диаметр - 120 мм, толщина 1,2 мм), однако отличается от него тем, что на одной стороне DVD-диска может быть записано до 4,7 Гбайт, а на двух - до 9,4 Гбайт. В случае использования двухслойной схемы записи на одной стороне можно разместить уже до 8,5 Гбайт информации, соответственно на двух сторонах - около 17 Гбайт. DVD-диски допускают перезапись информации.

Важнейшим фактором, сдерживающим широкое применение накопителей CD-R, CD-RW и DVD, является высокая стоимость как их самих, так и сменных носителей.

Контрольные вопросы

  1. Что такое внешняя память? Какие разновидности внешней памяти вы знаете?
  2. Что такое жесткий диск? Для чего он предназначен? Какую емкость имеют современные винчестеры?
  3. Каким образом осуществляются операции чтения и записи в НЖМД?
  4. В чем состоит операция форматирования магнитных дисков?
  5. Какие есть типы стандартных дисковых интерфейсов?
  6. Какие параметры влияют на быстродействие винчестера? Каким образом?
  7. Что такое флоппи-диск? Что общее и различное между ним и жестким диском?
  8. Каких правил следует придерживаться во время пользования дискетой?
  9. Какие вы знаете разновидности накопителей на оптических дисках? Чем они различаются между собою?
  10. Каким образом происходит считывание информации с компакт-дисков?
  11. В чем измеряется скорость передачи данных в накопителях на оптических носителях?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"


Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"

Процесс взаимодействия пользователя с персональным компьютером (ПК) непременно включает процедуры ввода входных данных и получение результатов обработки этих данных. Поэтому, обязательными составляющими типичной конфигурации ПК являются разнообразные устройства ввода-вывода, среди которых можно выделить стандартные устройства, без которых современный процесс диалога вообще невозможен, и периферийные, т.е дополнительные. К стандартным устройствам ввода-вывода относятся монитор, клавиатура и манипулятор "мышка".

Мониторы

Первые компьютеры мониторов не имели, был лишь набор мигающих светодиодов и распечатка результатов на принтере. С развитием компьютерной техники появились мониторы и сейчас они являются необходимой частью базовой конфигурации персонального компьютера.

Монитор (дисплей) - это стандартное устройство вывода, предназначенное для визуального отображения текстовых и графических данных. В зависимости от принципа действия, мониторы делятся на:

  • мониторы с электронно-лучевой трубкой;
  • дисплеи на жидких кристаллах.

Монитор с электронно-лучевой трубкой

Монитор с электронно-лучевой трубкой похож на телевизор. Электронно-лучевая трубка представляет собой электронно-вакуумное устройство в виде стеклянной колбы, в горловине которой находится электронная трубка, на дне - экран со слоем люминофора. При нагревании, электронная пушка излучает поток электронов, которые с высокой скоростью двигаются к экрану. Поток электронов (электронный луч) проходит через фокусирующую и отклоняющую катушку, которая направляет его в определенную точку люминофорного покрытия экрана. Под действием электронов, люминофор излучает свет, который видит пользователь. Люминофор характеризуется временем излучения после действия электронного потока. Электронный луч двигается довольно быстро, расчерчивая экран строками слева направо и сверху вниз. Во время развертки, то есть передвижения по экрану, луч влияет на те элементарные участки люминофорного покрытия, где может появиться изображение. Интенсивность луча постоянно изменяется, что обуславливает свечение соответствующих участков экрана. Поскольку, свечение исчезает очень быстро, электронный луч должен непрерывно пробегать по экрану, восстанавливая его.

Время излучения и частота обновления свечения должны соответствовать друг другу. Преимущественно, частота вертикальной развертки равна 70-85 Гц, то есть свечение на экране возобновляется 70-85 раз в секунду. Снижение частоты обновления приводит к миганию изображения, что утомляет глаза. Соответственно, повышение частоты обновления приводит к размыванию или удвоению контуров изображения.

Мониторы могут иметь как фиксированную частоту развертки, так и разные частоты в некотором диапазоне. Существует два режима развертки: Interlaced (черезстрочная) и Non Interlaced (построчная). Обычно, используют порядковую развертку. Луч сканирует экран построчно сверху вниз, формируя изображение за один проход. В режиме черезстрочной развертки, луч сканирует экран сверху вниз, но за два прохода: сначала нечетные строки, потом четные. Проход при черезстрочной развертке занимает вдвое меньше времени, чем формирование полного кадра в режиме построчной развертки. Поэтому время обновления для двух режимов одинаково.

Экраны для мониторов с электронно-лучевой трубкой бывают выпуклые и плоские. Стандартный монитор - выпуклый. В некоторых моделях используют технологию Trinitron, в которой поверхность экрана имеет небольшую кривизну по горизонтали, по вертикали экран абсолютно плоский. На таком экране наблюдается меньше бликов и улучшено качество изображения. Единственным недостатком можно считать высокую цену.

Дисплеи на жидких кристаллах (Liquid Crystal Display - LCD)

В дисплеях на жидких кристаллах безбликовый плоский экран и низкая мощность потребления электрической энергии (5 Вт, по сравнению, монитор с электронно-лучевой трубкой потребляет 100 Вт).

Существует три вида дисплеев на жидких кристаллах:

  • монохромный с пассивной матрицей;
  • цветной с пассивной матрицей;
  • цветной с активной матрицей.

В дисплеях на жидких кристаллах поляризационный фильтр создает две разные световые волны. Световая волна проходит сквозь жидкокристаллическую ячейку. Каждая ячейка имеет свой цвет. Жидкие кристаллы представляют собой молекулы, которые могут перетекать как жидкость. Это вещество пропускает свет, но под действием электрического заряда, молекулы изменяют свою ориентацию.

В дисплеях на жидких кристаллах с пассивной матрицей каждой ячейкой руководит электрический заряд (напряжение), который передается через транзисторную схему в соответствии с расположением ячеек в строках и столбцах матрицы экрана. Ячейка реагирует на импульс поступающего напряжения.

В дисплеях с активной матрицей каждая ячейка оснащена отдельным транзисторным ключом. Это обеспечивает высшую яркость изображения чем в дисплеях с пассивной матрицей, поскольку каждая ячейка находится под действием постоянного, а не импульсного электрического поля. Соответственно, активная матрица потребляет больше энергии. Кроме того, наличие отдельного транзисторного ключа для каждой ячейки усложняет производство, что, в свою очередь, увеличивает их цену.

Монохромные и цветные мониторы

По набору оттенков отображаемых цветов, мониторы делятся на цветные и черно-белые (монохромные). Монохромные мониторы дешевле, но не подходят для работы с операционной системой Windows. В цветных мониторах используют более сложные методы формирования изображения. В монохромных электронно-лучевых трубках существует одна электронная пушка, в цветных - три. Экран монохромной электронно-лучевой трубки покрыт люминофором одного цвета (с желтым, белым или зеленым излучением). Экран цветной электронно-лучевой трубки состоит из люминофорных триад (с красным, зеленым и синим излучением). Комбинации трех цветов предоставляет великое множество выходных оттенков.

Основные параметры мониторов

С точки зрения пользователя, основными характеристиками монитора являются размер по диагонали, разрешающая способность, частота регенерации (обновление) и класс защиты.

Размер монитора. Экран монитора измеряется по диагонали в дюймах. Размеры колеблются от 9 дюймов (23 см) до 42 дюймов (106 см). Чем больше экран, тем дороже монитор. Распространенными являются размеры 14, 15, 17, 19 и 21 дюйма. Мониторы большого размера лучше использовать для настольных издательских систем и графических работ, в которых нужно видеть все детали изображения. Оптимальными для массового использования являются 15- и 17-дюймовые мониторы.

Разрешающая способность. В графическом режиме работы изображение на экране монитора состоит из точек (пикселов). Количество точек по горизонтали и вертикали, которые монитор способный воссоздать четко и раздельно называется его разрешающей способностью. Выражение "разрешающая способность 800х600" означает, что монитор может выводить 600 горизонтальных строк по 800 точек в каждой. Стандартными являются такие режимы разрешающей способности: 800х600, 1024х768, 1152х864 и выше. Это свойство монитора определяется размером точки (зерна) экрана. Размер зерна экрана современных мониторов не превышает 0,28 мм. Чем больше разрешающая способность, тем лучше качество изображения. Качество изображения также связанно с размером экрана. Так, для удовлетворительного качества изображения в режиме 800х600 на 15-дюймовом мониторе можно ограничиться размером зерна 0,28 мм, для 14-дюймового монитора с тем же размером зерна в одном и том же видеорежиме качество мелких деталей изображения будет немного хуже.

Частота регенерации. Этот параметр иначе называется частотой кадровой развертки. Он показывает сколько раз в секунду монитор может полностью обновить изображение на экране. Частота регенерации измеряется в герцах (Гц). Чем больше частота, тем меньше усталость глаз и больше времени можно работать непрерывно. Сегодня минимально допустимой считается частота в 75 Гц, нормальной - 85 Гц, комфортной - 100 Гц и больше. Этот параметр зависит и от характеристик видеоадаптера.

Класс защиты монитора определяется стандартом, которому отвечает монитор с точки зрения требований техники безопасности. Сейчас общепринятыми считаются международные стандарты TCO-92, TCO-95 и ТСО-99, ограничивающие уровни электромагнитного излучения, эргометрические и экологические нормы, в рамках, безопасных для здоровья человека.

Видеоадаптер

Работой монитора руководит специальная плата, которую называют видеоадаптером (видеокартой). Вместе с монитором видеокарта создает видеоподсистему персонального компьютера. В первых компьютерах видеокарты не было. В оперативной памяти существовал экранный участок памяти, куда процессор заносил данные об изображении. Контроллер экрана считывал данные об яркости отдельных точек экрана из ячеек памяти и руководил разверткой горизонтального луча электронной пушки монитора.

При переходе от монохромных мониторов к цветным и с увеличением разрешающей способности экрана, участка видеопамяти стало недостаточно для хранения графических данных, а процессор не успевал обрабатывать изображения. Все операции, связанные с управлением экрана были отведены в отдельный блок - видеоадаптер.

Видеоадаптер имеет вид отдельной платы расширения, которую вставляют в определенный слот материнской платы (в современных ПК это слот AGP). Видеоадаптер выполняет функции видеоконтроллера, видеопроцессора и видеопамяти.

За время существования ПК изменилось несколько стандартов видеоадаптеров:

  • MDA (Monochrom Display Adapter) -монохромный,
  • CGA(Color Graphics Adapter) - 4 цвета,
  • EGA(Enchanced Graphics Adapter) -16 цветов,
  • VGA (Video Graphics Array) - 256 цветов,
  • SVGA (Super VGA) - до 16,7 млн. цветов.

На эти стандарты рассчитанны все программы, предназначенные для IBM-совместимых компьютеров.

Сформированное графическое изображение хранится во внутренней памяти видеоадаптера, которая называется видеопамятью. Необходимая емкость видеопамяти зависит от заданной разрешающей способности и палитры цветов, поэтому для работы в режимах с высокой разрешающей способностью и полноцветной гаммой нужно как можно больше видеопамяти. Если еще недавно типичными были видеоадаптеры с 2-4 Мбайт видеопамяти, то уже сегодня нормальной считается емкость в 32-64 Мбайт. Большинство современных видеокарт обладает возможностю расширения объема видеопамяти до 128 Мбайт, а также свойством видеоакселерации. Суть этого свойства состоит в том, что часть операций по построению изображения может происходить без выполнения математических вычислений в основном процессоре, а чисто аппаратным путем - преобразованием данных в специальных микросхемах видеоакселератора.

Видеоакселераторы могут входить в состав видеоадаптера, а могут поставляться в виде отдельной платы расширения, устанавливаемой на материнской плате и подсоединяемой к видеокарте. Различают два типа видеоакселераторов: для плоской (2D) и трехмерной (3D) графики. Первые более эффективны для работы с прикладными программами общего назначения и оптимизованные для ОС Windows, другие ориентированы на работу с разными мультимедийними и развлекательными программами.

Клавиатура

Клавиатура - это стандартное клавишное устройство ввода, предназначенное для ввода алфавитно-цифровых данных и команд управления. Комбинация монитора и клавиатуры обеспечивает простейший интерфейс пользователя: с помощью клавиатуры руководят компьютерной системой, а с помощью монитора получают результат.

Клавиатура относится к стандартным средствам ПК, поэтому для реализации ее основных функций не требуется наличие специальных системных программ (драйверов). Необходимое программное обеспечение для работы с клавиатурой находится в микросхеме постоянной памяти в составе базовой системы ввода-вывода BIOS. Именно поэтому, ПК реагирует на нажатие клавиш на клавиатуре сразу после включения. Клавиатура стационарного ПК, как правило, - это самостоятельный конструктивный блок, а в портативных ПК она входит в состав корпуса.

Клавиатуры имеют по 101-104 клавише, размещенных по стандарту QWERTY (в верхнем левом углу алфавитной части клавиатуры находятся клавиши Q, W, E, R, T, Y). Отличаются они лишь незначительными вариантами расположения и формой служебных клавиш, а также особенностями, обусловленными используемым языком.

Набор клавиш клавиатуры разбит на несколько функциональных групп:

  • алфавитно-цифровые;
  • функциональные;
  • управления курсором;
  • служебные;
  • клавиши дополнительной панели.

Основное назначение алфавитно-цифровых клавиш - ввод знаковой информации и команд, которые набираются по буквам. Каждая клавиша может работать в двух режимах (регистрах) и, соответственно, может использоваться для ввода нескольких символов. Переключение между нижним регистром (ввод маленьких символов) и верхним регистром (ввод больших символов) осуществляется при нажатии клавиши <SHIFT> (нефиксированное переключение) или с помощью клавиши <CAPS LOCK> (фиксированное переключение).

Группа функциональных клавиш включает двенадцать клавиш, обозначенных от F1 к F12, и расположена в верхней части клавиатуры. Функции этих клавиш зависят от конкретной, работающей в данный момент времени программы, а в некоторых случаях и от операционной системы. Жесткого закрепленного значения клавиш нет.

Клавиши управления курсором подают команды на передвижение курсора по экрану монитора относительно текущего изображения. Курсором называется экранный элемент, указывающий на место ввода знаковой информации. Эти клавиши разрешают руководить позицией ввода данных. Конкретное значение клавиш управления курсором может зависеть от программы. Тем не менее, чаще всего клавиши с стрелками служат для перемещения курсора в направлении указанном стрелкой или прокручивании текста по экрану, клавиши <Page Up> и <Page Down> прокручивают текст сразу на страницу вверх или вниз, соответственно, клавиша <Home> устанавливает курсор на начало строки, а клавиша <End> - на конец.

Служебные клавиши используются для разных вспомогательных целей, таких как, изменение регистра, режимов вставки, образование комбинаций "горячих" клавиш и т.д. К этой группе относятся такие клавиши, как <SHIFT>, <CAPS LOCK>, <Enter>, <Ctrl>, <Alt>, <Esc>, <Del>, <Insert>, <Tab>, <BackSpace> и прочие.

Группа клавиш дополнительной панели дублирует действие цифровых клавиш, клавиш управления курсором и некоторых служебных клавиш. Основное назначение - ввод чисел, поэтому клавиши размещены в порядке, удобном для такой работы. Переход в режим дублирования клавиш управления курсором и, наоборот, осуществляется нажатием на клавишу <Num Lock>. Кроме этого, клавиши дополнительной панели используются для ввода символов, имеющих расширенный код ASCII, но не имеющих соответствующей клавиши на клавиатуре.

Клавиатура ПК имеет свойство повторения знаков, что используется для автоматизации процесса ввода. Оно состоит в том, что при продолжительном нажатии клавиши начинается автоматический ввод символа, связанного с этой клавишей. При этом, настраиваемыми параметрами являются: интервал времени после нажатия, с завершением которого начинается автоматическое повторение символа и темп повторения (количество знаков за секунду).

Манипулятор "мышка"

Мышка - это устройство управления манипуляторного типа. Она имеет вид небольшой пластмассовой коробочки с двумя (или тремя) клавишами. Перемещение мышки по поверхности синхронизировано с перемещением графического объекта, который называется курсор мышки, по экрану монитора. В отличие от клавиатуры, мышка не является стандартным устройством управления, поэтому для работы с ней требуется наличие специальной системной программы - драйвера мышки. Драйвер мышки предназначен для интерпретации сигналов, поступающих от мышки, а также для обеспечения механизма передачи информации о положении и состоянии мышки операционной системе и другим прикладным программам. Драйвер мышки устанавливается при первом подключении мышки или при загрузке операционной системы.

Компьютером руководят перемещения мышки и кратковременные нажатия ее клавиш (эти нажатия называются кликами). Мышка не может непосредственно использоваться для ввода знаковой информации, ее принцип управления базируется на механизме событий. С точки зрения драйвера, все перемещения мышки и клики ее клавиш рассматриваются как события, анализируя которые, драйвер устанавливает, состоялось ли событие и в каком месте экрану находится в настоящее время курсор мышки. Эти данные передаются в прикладную программу, с которой работает пользователь, и по ним программа может определить, какую команду имел в виду пользователь и приступить к ее выполнению.

К числу параметров мышки, которыми может настроить пользователь, относят: чувствительность (характеризует величину перемещения курсора мышки по экрану при заданном перемещении мышки), функции левой и правой клавиш, а также чувствительность к двойному клику (определяет максимальный промежуток времени, на протяжении которого два отдельных клика клавиши рассматриваются как один двойной клик).

Контрольные вопросы

1. Какие устройства ввода-вывода образовывают простейший интерфейс пользователя?
2. Каким образом функционируют мониторы с электронно-лучевой трубкой? А дисплеи на жидких кристаллах?
3. Что означает выражение "разрешающая способность монитора составляет 1024х768"?
4. Какие потребительские параметры мониторов вы знаете?
5. Что такое видеоадаптер? Для чего он предназначен?
6. В чем состоит суть видеоакселерации?
7. Почему компьютер реагирует на нажатие клавиш на клавиатуре сразу после включения?
8. С помощью клавиш какой группы можно ввести расширенный код ASCII?
9. Где на клавиатуре расположены функциональные клавиши?
10. Почему манипулятор 'мышка' требует для своей работы наличия драйвера? Как работает драйвер мышки?
11. Что такое курсор клавиатуры и курсор мышки? Чем они отличаются?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"


Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"

Периферийными или внешними устройствами называют устройства, размещенные вне системного блока и задействованные на определенном этапе обработки информации. Прежде всего - это устройства фиксации выходных результатов: принтеры, плоттеры, модемы, сканеры и т.д. Понятие "периферийные устройства" довольно условное. К их числу можно отнести, например, накопитель на компакт-дисках, если он выполнен в виде самостоятельного блока и соединен специальным кабелем к внешнему разъему системного блока. И наоборот, модем может быть внутренним, то есть конструктивно выполненным как плата расширения, и тогда нет оснований относить его к периферийным устройствам.

Принтеры

Принтеры предназначены для вывода информации на твердые носители, большей частью на бумагу. Существует большое количество разнообразных моделей принтеров, которые различаются по принципу действия, интерфейсу, производительности и функциональным возможностями. По принципу действия различают: матричные, струйные и лазерные принтеры.

Матричные принтеры

До недавнего времени являлись самыми распространенными устройствами вывода информации, поскольку лазерные были дорогими, а струйные малонадежными. Основным преимуществом является низкая цена и универсальность, то есть возможность печатать на бумаге любого качества.

Принцип действия

Печать происходит при помощи встроенной в печатающий узел матрицы, состоящей из нескольких иголок. Бумага втягивается в принтер с помощью вала. Между бумагой и печатающим узлом располагается красящая лента. При ударе иголки по ленте, на бумаге появляются точки. Иголки, расположенные в печатающем узле управляются электромагнитом. Сам печатающий узел передвигается по горизонтали и управляется шаговым двигателем. Во время продвижения печатающего узла по строке, на бумаге появляются отпечатки символов, состаящие из точек. В памяти принтера хранятся коды отдельных букв, знаков и т.п.. Эти коды определяют, какие иголки и в какой момент следует активизировать для печати определенного символа.

Матрица может иметь 9, 18 или 24 иголки. Качество печати 9-иголочными принтерами невысокая. Для повышения качества, возможна печать 2-х и 4-х кратным прохождением узла по строке. Для современных матричных принтеров стандартом является матрица с 24 иглами. Иголки расположены в два ряда по 12 в каждом. Качество печати значительно выше. Матричные принтеры разрешают печатать сразу несколько копий документа. Для этого листы перекладывают копировальной калькой. Матричные принтеры не требовательны и могут печатать на поверхности любой бумаги - картоне, рулонной бумаге и т.п..

Характеристики матричных принтеров:

  • Скорость печати. Измеряется количеством знаков, печатаемых за секунду. Единица измерения cps (character per second - символов в секунду). Производители указывают максимальную скорость печати в черновом режиме (однопроходная печать). Однако, при выборе принтера следует учитывать, что для режима повышенного качества, а также при выводе графических изображений, скорость значительно ниже.
  • Объем памяти. Матричные принтеры оборудованы внутренней памятью (буфером), которая принимает данные от компьютера. В дешевых моделях объем буфера составляет 4-6 Кбайт. В более дорогих больше 200 Кбайт. Чем больше памяти, тем реже принтер обращается к компьютеру за определенной порцией данных, что позволяет центральному процессору выполнять другие задачи. Печать может происходить в фоновом режиме.
  • Разрешающая способность. Измеряется количеством точек, печатаемых на одном дюйме. Единица измерения dpi (dot per inch - точек на дюйм). Этот показатель важен для печати графических изображений.
  • Цветная печать. Существует несколько моделей цветных матричных принтеров. Но, качество печати 24-иголчатым принтером с применением разноцветной ленты намного хуже, чем качество печати на струйном принтере.
  • Шрифты. В памяти многих принтеров хранится широкий набор шрифтов. Но печать может осуществляться любым шрифтом True Type, разработанных для операционной системы Windows.

Струйные принтеры

Первые струйные принтеры выпустила фирма Hewlett Packard. Принцип действия похож на принцип действия матричных принтеров, но вместо иголок в печатающем узле расположены капиллярные распылители и резервуар с чернилами. В среднем, число распылителей от 16 до 64, но существуют модели, где количество распылителей для черных чернил до 300, а для цветных до 416. Резервуар с чернилами может располагаться отдельно и через капилляры соединяться с печатающим узлом, а может быть встроенным в печатающий узел и заменяться вместе с ним. Каждая конструкция имеет свои недостатки и преимущества. Встроенный в печатающий узел резервуар представляет собой конструктивно отдельное устройство (картридж), его очень легко заменить. Большинство современных струйных принтеров разрешают использовать картриджи для черно-белой и цветной печати.

Принцип действия

Существует два метода распыления чернила: пьезоэлектрический метод и метод газовых пузырьков. В первом, в распылител пьезоэлектрического узла установлен плоский пьезоэлемент, связанный с диафрагмой. При печати он сжимает и разжимает диафрагму, вызывая распыление чернил через распылитель. При попадании потока аэрозоля на носитель, печатается точка (используется в моделях принтеров фирм Epson, Brother). При методе газовых пузырьков, каждый распылитель оборудован нагревающим элементом. При прохождении сквозь элемент микросекундного импульса тока, чернила нагреваются до температуры кипения, и образуются пузырьки, выдавливающие чернила из распылителя, которые образовывают отпечатки на носителе (используется в моделях принтеров фирм Hewlett Packard, Canon).

Цветная печать выполняется путем смешивания разных цветов в определенных пропорциях. Преимущественно, в струйных принтерах реализуется цветовая модель CMYK (Cyan-Magenta-Yellow). Смешивание цветов не может дать чистый черный цвет и потому в составную модели входит черный цвет (Black). При цветной печати картридж имеет 3 или 4 резервуара с чернилами. Печатающий узел проходит по одному месту листа несколько раз, нанося нужное количество чернил разного цвета. После смешивания чернил, на листе появляется участок нужного цвета.

Характеристики струйных принтеров:

  • Скорость печатания. Печать в режиме нормального качества составляет 3-4 страницы в минуту. Цветная печать немного дольше.
  • Качество печатания. Дорогие модели струйных принтеров с большим количеством распылителей обеспечивают высокое качество изображения. Но большое значение имеет качество и толщина бумаги. Чтобы избавиться эффекта растекания чернил, некоторые принтеры применяют подогрев бумаги.
  • Разрешающая способность. Для печати графических изображений разрешающая способность составляет от 300 до 720 dpi.
  • Выбор носителя. Печать невозможна на рулонной бумаге.

Основным недостатком является засыхание чернил в распылителях. Устранить это можно лишь заменой картриджа. Чтобы не допустить засыхания, принтеры оборудованы устройствами очищения распылителей. По цене и качеству струйные принтеры идеально подходят для домашнего пользования. Заправка чернилами не является дорогой и банки чернил хватает на несколько лет.

Лазерные принтеры

Современные лазерные принтеры позволяют достичь более высокого качества печати. Качество приближено к фотографическому. Основным недостатком лазерных принтеров является высокая цена, но цены имеют тенденцию к снижению.

Принцип действия

У большинства лазерных принтеров используется механизм печати, как в копировальных аппаратах. Основным узлом является подвижный барабан, который наносит изображения на бумагу. Барабан представляет собой металлический цилиндр, покрытый слоем полупроводника. Поверхность барабана статически заряжается разрядом. Луч лазера, направленный на барабан, изменяет электростатический заряд в точке попадания и создает на поверхности барабана электростатическую копию изображения. После этого, на барабан наносится слой красящего порошка (тонера). Частицы тонера притягиваются лишь к электрически заряженным точкам. Лист втягивается с лотка и ему передается электрический заряд. При наложении на барабан, лист притягивает на себя частицы тонера с барабана. Для фиксации тонера, лист снова заряжается и проходит между валами, нагретыми до 180 градусов. По окончании, барабан разряжается, очищается от тонера и снова используется.

При цветной печати изображение формируется смешиванием тонеров разного цвета за 4 прохода листа через механизм. При каждом проходе на бумагу наносится определенное количество тонера одного цвета. Цветной лазерный принтер является сложным электронным устройством с 4 резервуарами для тонера, оперативной памятью, процессором и жестким диском, что соответственно увеличивает его габариты и цену.

Основные характеристики лазерных принтеров:

  • Скорость печатания. Определяется скоростью механического протягивания листа и скоростью обработки данных, поступающих с компьютера. Средняя скорость печати 4-16 страниц за минуту.
  • Разрешающая способность. В современных лазерных принтерах достигает 2400 dpi. Стандартным считается значение в 300 dpi.
  • Память. Работа лазерного принтера связана с огромными вычислениями. Например, при разрешающей способности 300 dpi, на странице формата А4 будет почти 9 млн. точек, и нужно рассчитать координаты каждой из них. Скорость обработки информации зависит от тактовой частоты процессора и объема оперативной памяти принтера. Объем оперативной памяти черно-белого лазерного принтера составляет не меньше 1 Мбайт, в цветных лазерных принтерах значительно больше.
  • Бумага. Используется качественная бумага формата А4. Существуют модели для формата А3. В некоторых лазерных принтерах есть возможность использования рулонной бумаги.

Срок и качество работы лазерного принтера зависит от барабана. Ресурс барабана дешевых моделей - 40-60 тысяч страниц.

Подсоединение принтера

После физического подсоединения к компьютеру, принтер нужно программно установить и настроить. В Windows процессом печати руководит не программа, а операционная система. Поэтому настройка выполняется с помощью программы Control Panel, после чего принтер становится доступным для всех программ. Управление принтером осуществляют драйверы. Они поставляются вместе с принтером, но драйверы популярных моделей содержатся в комплекте Windows. При отсутствии "родного" драйвера, можно попробовать подобрать похожий из набора существующих драйверов или найти в Интернете на сайте фирмы-производителя.

Сканеры

Сканер - это устройство, позволяющее вводить в компьютер черно-белое или цветное изображения, считывать графическую и текстовую информацию. Сканер используют в случае, когда возникает потребность ввести в компьютер из имеющегося оригинала текст и/или графическое изображение для его дальнейшей обработки (редактирование и т.д.). Ввод такой информации с помощью стандартных устройств ввода требует много времени. Сканированная информация после обрабатывается с помощью специального программного обеспечения (например, программой FineReader) и сохраняется в виде текстового или графического файла.

Принцип действия

Основным элементом сканера является CCD-матрица (Charge Coupled Device - устройство с зарядовой связью) или PMT (PhotoMultiplier Tube - фотомножитель). Колбы-фотомножители используются лишь в сложных и дорогих барабанных профессиональных сканерах, поэтому далее рассмотрен лишь принцип действия сканеров с CCD-матрицей.

CCD-матрица - это набор диодов, которые реагируют на свет при действии внешнего напряжения. От качества матрицы зависит качество распознавания изображения. Дешевые модели распознают наличие/отсутствие цвета, сложные модели - оттенки серого цвета, еще более сложные - все цвета. Сканируемый объект, освещается ксеноновой лампой или набором светодиодов. Отраженный луч с помощью системы зеркал или линз проектируется на CCD-матрицу. Под действием света и внешнего напряжения, матрица генерирует аналоговый сигнал, который изменяется при перемещении относительно ее листа и интенсивности отображения разных элементарных фрагментов. Сигнал подается на аналогово-цифровой преобразователь, где он оцифровуется (представляется в виде набора нулей и единиц) и передается в память компьютера. Существует два способа сканирования: перемещение листа относительно неподвижной CCD-матрицы или перемещение светочувствительного элемента при неподвижном листе.

Классификация сканеров

Существует немало моделей сканеров, которые различаются методом сканирования, допустимым размером оригинала и качеством оптической системы. По способу организации перемещения считывающего узла относительно оригинала сканеры делятся на планшетные, барабанные и ручные. В планшетных сканерах оригинал кладут на стекло, под которым двигается оптико-электронное считывающее устройство. В барабанных сканерах оригинал через входную щель втягивается барабаном в транспортный тракт и пропускается мимо неподвижного считывающего устройства. Барабанные сканеры не дают возможности сканировать книги, переплетенные брошюры и т.п.. Ручной сканер необходимо плавно перемещать вручную по поверхности оригинала, что не очень удобно. При систематическом использовании лучше иметь, хоть и более дорогой, настольный планшетный сканер.

Основные технические характеристики сканеров:

Разрешающая способность. Сканер рассматривает любой объект как набор отдельных точек (пикселов). Плотность пикселов (количество на единицу площади) называется разрешающей способностью сканера и измеряется в dpi (dots per inch - точек на дюйм). Пиксели располагаются строками, образовывая изображение. Процесс сканирования происходит по строкам, вся строка сканируется одновременно. Обычная разрешающая способность сканера составляет 200-720 dpi. Большее значение (свыше 1000) отображает интерполяционную разрешающую способность, достигаемую программным путем с использованием математической обработки параметров расположенных возле точек изображения.

Качество отсканированного материала зависит также от оптической разрешающей способности (определяется количеством светочувствительных диодов CCD-матрицы на дюйм) и механической разрешающей способности (определяется дискретностью движения светочувствительного элемента или системы зеркал относительно листа). Выбор разрешающей способности определяется дальнейшим применением результатов сканирования: для художественных изображений, печатаемых на фотонаборных машинах разрешающая способность должна составлять 1000-1200 dpi, для печати изображения на лазерном или струйном принтере - 300-600 dpi, для просмотра изображения на экране монитора - 72-150 dpi, для распознавания текста - 200-400 dpi.

Глубина представления цветов. При преобразовании оригинала в цифровую форму, сохраняются данные о любом пикселе изображения. Простые сканеры определяют наличие или отсутствие цвета, результирующее изображение будет черно-белым. Для представления пикселов достаточно одного разряда (0 или 1). Для передачи оттенков серого между черным и белым цветом необходимо как минимум 4 разряда (16 оттенков) или 8 разрядов (256 оттенков). Чем больше разрядов, тем качественней передаются цвета. Большинство современных цветных сканеров поддерживает глубину цвета 24 разряда. Соответственно, сканер разрешает распознавать около 16 млн. цветов и можно качественно сканировать фотографии. На рынке сканеров есть модели, которые имеют глубину представления цвета 30 и 34 разряда.

Динамический диапазон. Диапазон оптической плотности, определяет спектр полутонов. Оптическая плотность определяется как отношение падающего света к отраженному и колеблется в диапазоне от 0,0 (абсолютно белое тело) до 4,0 (абсолютно черное тело). Значение диапазона дополняется буквой D и определяет степень его чувствительности. Большинство планшетных сканеров имеют стандартный диапазон 2,4 D, неважно различают близкие оттенки одного цвета, но этого достаточно для непрофессионального пользователя.

Метод сканирования. Качество сканированного цветного изображения зависит от метода накопления сканером данных. Различают два основных метода, которые отличаются количеством проходов CCD-матрицы над оригиналом. Первые сканеры использовали 3-проходное сканирование. При каждом проходе сканировался один из цветов палитры RGB. Современные сканеры используют однопроходную методику, которая разделяет световой луч на составляющие с помощью призмы.

Область сканирования. Максимальный размер сканируемого изображения. Ручные сканеры - до 105 мм, барабанные, планшетные сканеры - от формата А4 до Full Legar (8.5'x14').

Скорость сканирования. Нет стандартной методики, которая определяет производительность сканера. Производители указывают количество миллисекунд сканирования одной строки. Но нужно учитывать также способ подсоединения к компьютеру, драйвер, схему передачи цветов, разрешающую способность. Поэтому скорость сканирования определяется экспериментальным путем.

Модемы

Модем - это устройство, предназначенное для подсоединения компьютера к обычной телефонной линии. Название происходит от сокращения двух слов - Модуляция и Демодуляция.

Компьютер вырабатывает дискретные электрические сигналы (последовательности двоичных нулей и единиц), а по телефонным линиям информация передается в аналоговой форме (то есть в виде сигнала, уровень которого изменяется непрерывно, а не дискретно). Модемы выполняют цифро-аналоговое и аналого-цифровое преобразования. При передаче данных, модемы накладывают цифровые сигналы компьютера на непрерывную частоту телефонной линии (модулируют ее), а при их приеме демодулируют информацию и передают ее в цифровой форме в компьютер. Модемы передают данные по обычным, то есть комутированным, телефонным каналам со скоростью от 300 до 56 000 бит в секунду, а по арендованным (выделенным) каналам скорость может быть и выше. Кроме того, современные модемы осуществляют сжатие данных перед отправлением, и соответственно, реальная скорость может превышать максимальную скорость модема.

По конструктивному выполнению модемы бывают встроенными (вставляются в системный блок компьютера в один из слотов расширения) и внешними (подключаются через один из коммуникационных портов, имеют отдельный корпус и собственный блок питания). Однако, без соответствующего коммуникационного программного обеспечения, важнейшей составляющей которого является протокол, модемы не могут работать. Наиболее распространенными протоколами модемов являются v.32 bis, v.34, v.42 bis и прочие.

Современные модемы для широкого круга пользователей имеют встроенные возможности отправления и получения факсимильных сообщений. Такие устройства называются факсами-модемами. Также, есть возможность поддержки языковых функций, с помощью звукового адаптера.

На выбор типа модема влияют следующие факторы:

  • цена: внешние модемы стоят дороже, поскольку в цену входит стоимость корпуса и источника питания;
  • наличие свободных портов/слотов: внешний модем подсоединяется к последовательному порту. Внутренний модем к слоту на материнской плате. Если порты или слоты занятые, нужно выбрать одно из устройств;
  • удобство пользования: на корпусе внешнего модема имеются индикаторы, отображающие его состояние, а также выключатель источника питания. Для установки внешнего модема не нужно разбирать корпус компьютера.

Контрольные вопросы

1. Какие устройства называются периферийными? Почему?
2. Опишите принцип действия матричных принтеров.
3. Какие вы знаете потребительские характеристики принтеров?
4. В каких единицах измеряется разрешающая способность принтеров и сканеров?
5. В чем состоит принцип действия лазерных принтеров?
6. Какая цветовая модель реализована в цветных струйных принтерах?
7. Для чего предназначенные сканеры? В каких случаях их целесообразно использовать?
8. Чем определяется выбор разрешающей способность сканирования?
9. Какие типы сканеров вы знаете? В чем между ними разница?
10. Какие функции выполняют модемы?
11. Какие факторы влияют на выбор типа модема?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"


Лекция 8 " Программное обеспечение"

В основу работы компьютеров положен программный принцип управления, состоящий в том, что компьютер выполняет действия по заранее заданной программе. Этот принцип обеспечивает универсальность использования компьютера: в определенный момент времени решается задача соответственно выбранной программе. После ее завершения в память загружается другая программа и т.д.

Программа - это запись алгоритма решения задачи в виде последовательности команд или операторов языком, который понимает компьютер. Конечной целью любой компьютерной программы является управление аппаратными средствами.

Для нормального решения задач на компьютере нужно, чтобы программа была отлажена, не требовала доработок и имела соответствующую документацию. Поэтому, относительно работы на компьютере часто используют термин программное обеспечение (software), под которым понимают совокупность программ, процедур и правил, а также документации, касающихся функционирования системы обработки данных.

Программное и аппаратное обеспечение в компьютере работают в неразрывной связи и взаимодействии. Состав программного обеспечения вычислительной системы называется программной конфигурацией. Между программами существует взаимосвязь, то есть работа множества программ базируется на программах низшего уровня.

Междупрограммный интерфейс - это распределение программного обеспечения на несколько связанных между собою уровней. Уровни программного обеспечения представляют собой пирамиду, где каждый высший уровень базируется на программном обеспечении предшествующих уровней. Схематично структура программного обеспечения приведена на рис. 1.

Прикладной уровень

Служебный уровень

Системный уровень

Базовый уровень

Базовый уровень

Базовый уровень является низшим уровнем программного обеспечения. Отвечает за взаимодействие с базовыми аппаратными средствами. Базовое программное обеспечение содержится в составе базового аппаратного обеспечения и сохраняется в специальных микросхемах постоянного запоминающего устройства (ПЗУ), образуя базовую систему ввода-вывода BIOS. Программы и данные записываются в ПЗУ на этапе производства и не могут быть изменены во время эксплуатации.

Системный уровень

Системный уровень - является переходным. Программы этого уровня обеспечивают взаимодействие других программ компьютера с программами базового уровня и непосредственно с аппаратным обеспечением. От программ этого уровня зависят эксплуатационные показатели всей вычислительной системы. При подсоединении к компьютеру нового оборудования, на системном уровне должна быть установлена программа, обеспечивающая для остальных программ взаимосвязь с устройством. Конкретные программы, предназначенные для взаимодействия с конкретными устройствами, называют драйверами.

Другой класс программ системного уровня отвечает за взаимодействие с пользователем. Благодаря ему, можно вводить данные в вычислительную систему, руководить ее работой и получать результат в удобной форме. Это средства обеспечения пользовательского интерфейса, от них зависит удобство и производительность работы с компьютером.

Совокупность программного обеспечения системного уровня образует ядро операционной системы компьютера. Наличие ядра операционной системы - это первое условие для возможности практической работы пользователя с вычислительной системой. Ядро операционной системы выполняет такие функции: управление памятью, процессами ввода-вывода, файловой системой, организация взаимодействия и диспетчеризация процессов, учет использования ресурсов, обработка команд и т.д.

Служебный уровень

Программы этого уровня взаимодействуют как с программами базового уровня, так и с программами системного уровня. Назначение служебных программ (утилит) состоит в автоматизации работ по проверке и настройки компьютерной системы, а также для улучшения функций системных программ. Некоторые служебные программы (программы обслуживания) сразу входят в состав операционной системы, дополняя ее ядро, но большинство являются внешними программами и расширяют функции операционной системы. То есть, в разработке служебных программ отслеживаются два направления: интеграция с операционной системой и автономное функционирование.

Классификация служебных программных средств

1. Диспетчеры файлов (файловые менеджеры). С их помощью выполняется большинство операций по обслуживанию файловой структуры: копирование, перемещение, переименование файлов, создание каталогов (папок), уничтожение объектов, поиск файлов и навигация в файловой структуре. Базовые программные средства содержатся в составе программ системного уровня и устанавливаются вместе с операционной системой

2. Средства сжатия данных (архиваторы). Предназначены для создания архивов. Архивные файлы имеют повышенную плотность записи информации и соответственно, эффективнее используют носители информации.

3. Средства диагностики. Предназначены для автоматизации процессов диагностики программного и аппаратного обеспечения. Их используют для исправления ошибок и для оптимизации работы компьютерной системы.

4. Программы инсталляции (установки). Предназначены для контроля за добавлением в текущую программную конфигурацию нового программного обеспечения. Они следят за состоянием и изменением окружающей программной среды, отслеживают и протоколируют образование новых связей, утерянных во время уничтожения определенных программ. Простые средства управления установлением и уничтожением программ содержатся в составе операционной системы, но могут использоваться и дополнительные служебные программы.

5. Средства коммуникации. Разрешают устанавливать соединение с удаленными компьютерами, передают сообщения электронной почты, пересылают факсимильные сообщения и т.п..

6. Средства просмотра и воспроизведения. Преимущественно, для работы с файлами, их необходимо загрузить в "родную" прикладную программу и внести необходимые исправления. Но, если редактирование не нужно, существуют универсальные средства для просмотра (в случае текста) или воспроизведения (в случае звука или видео) данных.

7. Средства компьютерной безопасности. К ним относятся средства пассивной и активной защиты данных от повреждения, несанкционированного доступа, просмотра и изменения данных. Средства пассивной защиты - это служебные программы, предназначенные для резервного копирования. Средства активной защиты применяют антивирусное программное обеспечение. Для защиты данных от несанкционированного доступа, их просмотра и изменения используют специальные системы, базирующиеся на криптографии.

Прикладной уровень

Программное обеспечение этого уровня представляет собой комплекс прикладных программ, с помощью которых выполняются конкретные задачи (производственных, творческих, развлекательных и учебных). Между прикладным и системным программным обеспечением существует тесная взаимосвязь. Универсальность вычислительной системы, доступность прикладных программ и широта функциональных возможностей компьютера непосредственно зависят от типа имеющейся операционной системы, системных средств, помещенных в ее ядро и взаимодействии комплекса человек-программа-оборудование.

Классификация прикладного программного обеспечения

1. Текстовые редакторы. Основные функции - это ввод и редактирование текстовых данных. Для операций ввода, вывода и хранения данных текстовые редакторы используют системное программное обеспечение. С этого класса прикладных программ начинают знакомство с программным обеспечением и на нем приобретают первые привычки работы с компьютером.

2. Текстовые процессоры. Разрешают форматировать, то есть оформлять текст. Основными средствами текстовых процессоров являются средства обеспечения взаимодействия текста, графики, таблиц и других объектов, составляющих готовый документ, а также средства автоматизации процессов редактирования и форматирования. Современный стиль работы с документами имеет два подхода: работа с бумажными документами и работа с электронными документами. Приемы и методы форматирования таких документов различаются между собой, но текстовые процессоры способны эффективно обрабатывать оба вида документов.

3. Графические редакторы. Широкий класс программ, предназначенных для создания и обработки графических изображений. Различают три категории:

  • растровые редакторы;
  • векторные редакторы;
  • 3-D редакторы (трехмерная графика).

В растровых редакторах графический объект представлен в виде комбинации точек (растров), которые имеют свою яркость и цвет. Такой подход эффективный, когда графическое изображение имеет много цветов и информация про цвет элементов намного важнее, чем информация про их форму. Это характерно для фотографических и полиграфических изображений. Применяют для обработки изображений, создания фотоэффектов и художественных композиций.

Векторные редакторы отличаются способом представления данных изображения. Объектом является не точка, а линия. Каждая линия рассматривается, как математическая кривая ІІІ порядка и представлена формулой. Такое представление компактнее, чем растровое, данные занимают меньше места, но построение объекта сопровождается пересчетом параметров кривой в координаты экранного изображения, и соответственно, требует более мощных вычислительных систем. Широко применяются в рекламе, оформлении обложек полиграфических изданий.

Редакторы трехмерной графики используют для создания объемных композиций. Имеют две особенности: разрешают руководить свойствами поверхности в зависимости от свойств освещения, а также разрешают создавать объемную анимацию.

4. Системы управления базами данных (СУБД). Базой данных называют большие массивы данных, организованные в табличные структуры. Основные функции СУБД:

  • создание пустой структуры базы данных;
  • наличие средств ее заполнения или импорта данных из таблиц другой базы;
  • возможность доступа к данных, наличие средств поиска и фильтраци.

В связи с распространением сетевых технологий, от современных СУБД требуется возможность работы с отдаленными и распределенными ресурсами, которые находятся на серверах Интернета.

5. Электронные таблицы. Предоставляют комплексные средства для хранения разных типов данных и их обработки. Основной акцент смещен на преобразование данных, предоставлен широкий спектр методов для работы с числовыми данными. Основная особенность электронных таблиц состоит в автоматическом изменении содержимого всех ячеек при изменении отношений, заданных математическими или логическими формулами.

Широкое применение находят в бухгалтерском учете, анализе финансовых и торговых рынков, средствах обработки результатов экспериментов, то есть в автоматизации регулярно повторяемых вычислений больших объемов числовых данных.

6. Системы автоматизированного проектирования (CAD-системы). Предназначены для автоматизации проектно-конструкторских работ. Применяются в машиностроении, приборостроении, архитектуре. Кроме графических работ, разрешают проводить простые расчеты и выбор готовых конструктивных элементов из существующей базы данных.

Особенность CAD-систем состоит в автоматическом обеспечении на всех этапах проектирования технических условий, норм и правил. САПР являются необходимым компонентом для гибких производственных систем (ГВС) и автоматизированных систем управления технологическими процессами (АСУ ТП).

7. Настольные издательские системы. Автоматизируют процесс верстки полиграфических изданий. Издательские системы отличаются расширенными средствами управления взаимодействия текста с параметрами страницы и графическими объектами, но имеют более слабые возможности по автоматизации ввода и редактирования текста. Их целесообразно применять к документам, которые предварительно обработаны в текстовых процессорах и графических редакторах.

8. Редакторы HTML (Web-редакторы). Особый класс редакторов, объединяющих в себе возможности текстовых и графических редакторов. Предназначены для создания и редактирования Web-страниц Интернета. Программы этого класса можно использовать при подготовке электронных документов и мультимедийних изданий.

9. Браузеры (средства просмотра Web-документов). Программные средства предназначены для просмотра электронных документов, созданных в формате HTML. Восроизводят, кроме текста и графики, музыку, человеческий язык, радиопередачи, видеоконференции и разрешают работать с электронной почтой.

10. Системы автоматизированного перевода. Различают электронные словари и программы перевода языка.

Электронные словари - это средства для перевода отдельных слов в документе. Используются профессиональными переводчиками, которые самостоятельно переводят текст.

Программы автоматического перевода используют текст на одном языке и выдают текст на другом, то есть автоматизируют перевод. При автоматизированном переводе невозможно получить качественный исходный текст, поскольку все сводится к переводу отдельных лексических единиц. Но, для технического текста, этот барьер снижен.

Программы автоматического перевода целесообразно использовать:

  • при абсолютном незнании иностранного языка;
  • при необходимости быстрого ознакомления с документом;
  • для перевода на иностранный язык;
  • для создания черновика, который потом будет подправлен полноценным переводом.

11. Интегрированные системы делопроизводства. Средства для автоматизации рабочего места руководителя. В частности, это функции создания, редактирования и форматирования документов, централизация функций электронной почты, факсимильной и телефонной связи, диспетчеризация и мониторинг документооборота предприятия, координация работы подразделов, оптимизация административно-хозяйственной деятельности и поставка оперативной и справочной информации.

12. Бухгалтерские системы. Имеют функции текстовых, табличных редакторов и СУБД. Предназначены для автоматизации подготовки начальных бухгалтерских документов предприятия и их учета, регулярных отчетов по итогам производственной, хозяйственной и финансовой деятельности в форме, приемлемой для налоговых органов, внебюджетных фондов и органов статистического учета.

13. Финансовые аналитические системы. Используют в банковских и биржевых структурах. Разрешают контролировать и прогнозировать ситуацию на финансовых, торговых рынках и рынках сырья, выполнять анализ текущих событий, готовить отчеты.

14. Экспертные системы. Предназначены для анализа данных, содержащихся в базах знаний и выдачи результатов, при запросе пользователя. Такие системы используются, когда для принятия решения нужны широкие специальные знания. Используются в медицине, фармакологии, химии, юриспруденции. С использованием экспертных систем связана область науки, которая носит название инженерии знаний.

Инженеры знаний - это специалисты, являющиеся промежуточным звеном между разработчиками экспертных систем (программистами) и ведущими специалистами в конкретных областях науки и техники (экспертами).

15. Геоинформационные системы (ГИС). Предназначены для автоматизации картографических и геодезических работ на основе информации, полученной топографическим или аэрографическими методами.

16. Системы видеомонтажа. Предназначены для цифровой обработки видеоматериалов, монтажа, создания видеоэффектов, исправления дефектов, добавления звука, титров и субтитров. Отдельные категории представляют учебные, справочные и развлекательные системы и программы. Характерной особенностью являются повышенные требования к мультимедийной составляющей.

17. Инструментальные языки и системы программирования. Эти средства служат для разработки новых программ. Компьютер "понимает" и может выполнять программы в машинном коде. Каждая команда при этом имеет вид последовательности нулей и единиц. Писать программы на машинном языке крайне неудобно. Поэтому программы разрабатываются на языке, понятном человеку (инструментальный язык или алгоритмический язык программирования), после чего, специальной программой, которая называется транслятором, текст программы переводится (транслируется) на машинный код.

Трансляторы бывают двух типов:

  • интерпретаторы,
  • компиляторы.

Интерпретатор читает один оператор программы, анализирует его и сразу выполняет, после чего переходит к обработке следующего оператора.

Компилятор сначала читает, анализирует и переводит на машинный код всю программу и только после завершения всей трансляции эта программа выполняется.

Инструментальные языки делятся на языки низкого уровня (близкие к машинному языку) и языки высокого уровня (близкие к человеческим языкам). К языкам низкого уровня принадлежат ассемблеры, а высокого - Pascal, Basic, C/C++, языки баз данных и т.д. В систему программирования, кроме транслятора, входит текстовый редактор, компоновщик, библиотека стандартных программ, отладчик, визуальные средства автоматизации программирования. Примерами таких систем являются Delphi, Visual Basic, Visual C++, Visual FoxPro и др.

Контрольные вопросы

  1. Что принято понимать под термином 'software'?
  2. На какие уровни делится программное обеспечение?
  3. Совокупность программ какого уровня образовывают ядро операционной системы?
  4. Какие функции выполняет ядро операционной системы?
  5. Для чего предназначены программы базового уровня?
  6. Какие классы программ служебного уровня вы знаете?
  7. С помощью программ какого класса можно осуществлять ввод, редактирование и оформление текстовых данных?
  8. Какие вы знаете категории графических редакторов?
  9. В каких случаях целесообразно использовать системы автоматизированного перевода?
  10. Что такое интерпретатор и компилятор? Какая между ними разница?

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"


Лекция 9 "Сжатие данных"

Характерной особенностью большинства типов данных является их избыточность. Степень избыточности данных зависит от типа данных. Например, для видеоданных степень избыточности в несколько раз больше чем для графических данных, а степень избыточности графических данных, в свою очередь, больше чем степень избыточности текстовых данных. Другим фактором, влияющим на степень избыточности является принятая система кодирования. Примером систем кодирования могут быть обычные языки общения, которые являются ни чем другим, как системами кодирования понятий и идей для высказывания мыслей. Так, установлено, что кодирование текстовых данных с помощью средств русского языка дает в среднем избыточность на 20-25% большую чем кодирование аналогичных данных средствами английского языка.

Для человека избыточность данных часто связана с качеством информации, поскольку избыточность, как правило, улучшает понятность и восприятие информации. Однако, когда речь идет о хранении и передаче информации средствами компьютерной техники, то избыточность играет отрицательную роль, поскольку она приводит к возрастанию стоимости хранения и передачи информации. Особенно актуальной эта проблема стает в случае обработки огромных объемов информации при незначительных объемах носителей данных. В связи с этим, постоянно возникает проблема уменьшения избыточности или сжатия данных. Если методы сжатия данных применяются к готовым файлам, то часто вместо термина "сжатие данных" употребляют термин "архивация данных", сжатый вариант данных называют архивом, а программные средства, которые реализуют методы сжатия называются архиваторами.

В зависимости от того, в каком объекте размещены данные, подлежащие сжатию различают:

  1. Сжатие (архивация) файлов: используется для уменьшения размеров файлов при подготовке их к передаче каналами связи или к транспортированию на внешних носителях маленькой емкости;
  2. Сжатие (архивация) папок: используется как средство уменьшения объема папок перед долгим хранением, например, при резервном копировании;
  3. Сжатие (уплотнение) дисков: используется для повышения эффективности использования дискового просторную путем сжатия данных при записи их на носителе информации (как правило, средствами операционной системы).

Существует много практических алгоритмов сжатия данных, но все они базируются на трех теоретических способах уменьшения избыточности данных. Первый способ состоит в изменении содержимого данных, второй - в изменении структуры данных, а третий - в одновременном изменении как структуры, так и содержимого данных.

Если при сжатии данных происходит изменение их содержимого, то метод сжатия называется необратимым, то есть при восстановлении (разархивировании) данных из архива не происходит полное восстановление информации. Такие методы часто называются методами сжатия с регулированными потерями информации. Понятно, что эти методы можно применять только для таких типов данных, для которых потеря части содержимого не приводит к существенному искажению информации. К таким типам данных относятся видео- и аудиоданные, а также графические данные. Методы сжатия с регулированными потерями информации обеспечивают значительно большую степень сжатия, но их нельзя применять к текстовым данным. Примерами форматов сжатия с потерями информации могут быть:

  • JPEG - для графических данных;
  • MPG - для для видеоданных;
  • MP3 - для аудиоданных.

Если при сжатии данных происходит только изменение структуры данных, то метод сжатия называется обратимым. В этом случае, из архива можно восстановить информацию полностью. Обратимые методы сжатия можно применять к любым типам данных, но они дают меньшую степень сжатия по сравнению с необратимыми методами сжатия. Примеры форматов сжатия без потери информации:

  • GIF, TIFF - для графических данных;
  • AVI - для видеоданных;
  • ZIP, ARJ, RAR, CAB, LH - для произвольных типов данных.

Существует много разных практических методов сжатия без потери информации, которые, как правило, имеют разную эффективность для разных типов данных и разных объемов. Однако, в основе этих методов лежат три теоретических алгоритма:

  • алгоритм RLE (Run Length Encoding);
  • алгоритмы группы KWE(KeyWord Encoding);
  • алгоритм Хаффмана.

Алгоритм RLE

В основе алгоритма RLE лежит идея выявления повторяющихся последовательностей данных и замены их более простой структурой, в которой указывается код данных и коэффициент повторения. Например, пусть задана такая последовательность данных, что подлежит сжатию:

1 1 1 1 2 2 3 4 4 4

В алгоритме RLE предлагается заменить ее следующей структурой: 1 4 2 2 3 1 4 3, где первое число каждой пары чисел - это код данных, а второе - коэффициент повторения. Если для хранения каждого элемента данных входной последовательности отводится 1 байт, то вся последовательность будет занимать 10 байт памяти, тогда как выходная последовательность (сжатый вариант) будет занимать 8 байт памяти. Коэффициент сжатия, характеризующий степень сжатия, можно вычислить по формуле:

где Vx- объем памяти, необходимый для хранения выходной (результирующей) последовательности данных, Vn- входной последовательности данных.

Чем меньше значение коэффициента сжатия, тем эффективней метод сжатия. Понятно, что алгоритм RLE будет давать лучший эффект сжатия при большей длине повторяющейся последовательности данных. В случае рассмотренного выше примера, если входная последовательность будет иметь такой вид: 1 1 1 1 1 1 3 4 4 4, то коэффициент сжатия будет равен 60%. В связи с этим большая эффективность алгоритма RLE достигается при сжатии графических данных (в особенности для однотонных изображений).

Алгоритмы группы KWE

В основе алгоритма сжатия по ключевым словам положен принцип кодирования лексических единиц группами байт фиксированной длины. Примером лексической единицы может быть обычное слово. На практике, на роль лексических единиц выбираются повторяющиеся последовательности символов, которые кодируются цепочкой символов (кодом) меньшей длины. Результат кодирования помещается в таблице, образовывая так называемый словарь.

Существует довольно много реализаций этого алгоритма, среди которых наиболее распространенными являются алгоритм Лемпеля-Зіва (алгоритм LZ) и его модификация алгоритм Лемпеля-Зіва-Велча (алгоритм LZW). Словарем в данном алгоритме является потенциально бесконечный список фраз. Алгоритм начинает работу с почти пустым словарем, который содержит только одну закодированную строку, так называемая NULL-строка. При считывании очередного символа входной последовательности данных, он прибавляется к текущей строке. Процесс продолжается до тех пор, пока текущая строка соответствует какой-нибудь фразе из словаря. Но рано или поздно текущая строка перестает соответствовать какой-нибудь фразе словаря. В момент, когда текущая строка представляет собой последнее совпадение со словарем плюс только что прочитанный символ сообщения, кодер выдает код, который состоит из индекса совпадения и следующего за ним символа, который нарушил совпадение строк. Новая фраза, состоящая из индекса совпадения и следующего за ним символа, прибавляется в словарь. В следующий раз, если эта фраза появится в сообщении, она может быть использована для построения более длинной фразы, что повышает меру сжатия информации.

Алгоритм LZW построен вокруг таблицы фраз (словаря), которая заменяет строки символов сжимаемого сообщения в коды фиксированной длины. Таблица имеет так называемое свойством опережения, то есть для каждой фразы словаря, состоящей из некоторой фразы w и символа К, фраза w тоже заносится в словарь. Если все части словаря полностью заполнены, кодирование перестает быть адаптивным (кодирование происходит исходя из уже существующих в словаре фраз).

Алгоритмы сжатия этой группы наиболее эффективны для текстовых данных больших объемов и малоэффективны для файлов маленьких размеров (за счет необходимости сохранение словаря).

Алгоритм Хаффмана

В основе алгоритма Хаффмана лежит идея кодирования битовыми группами. Сначала проводится частотный анализ входной последовательности данных, то есть устанавливается частота вхождения каждого символа, встречащегося в ней. После этого, символы сортируются по уменьшению частоты вхождения.

Основная идея состоит в следующем: чем чаще встречается символ, тем меньшим количеством бит он кодируется. Результат кодирования заносится в словарь, необходимый для декодирования. Рассмотрим простой пример, иллюстрирующий работу алгоритма Хаффмана.

Пусть задан текст, в котором бурва 'А' входит 10 раз, буква 'В' - 8 раз, 'С'- 6 раз , 'D' - 5 раз, 'Е' и 'F' - по 4 раза. Тогда один из возможных вариантов кодирования по алгоритму Хаффмана приведен в таблицы 1.

Таблица 1.

Символ | Частота вхождения | Битовый код
A | 10 | 00
B | 8 | 01
C | 6 | 100
D | 5 | 101
E | 4 | 110
F | 4 | 111

Как видно из таблицы 1, размер входного текста до сжатия равен 37 байт, тогда как после сжатия - 93 бит, то есть около 12 байт (без учета длины словаря). Коэффициент сжатия равен 32%. Алгоритм Хаффмана универсальный, его можно применять для сжатия данных любых типов, но он малоэффективен для файлов маленьких размеров (за счет необходимости сохранение словаря).

На практике программные средства сжатия данных синтезируют эти три "чистых" алгоритмы, поскольку их эффективность зависит от типа и объема данных. В таблице 2 приведены распространенные форматы сжатия и соответствующие им программыи-архиваторы, использующиеся на практике.

Таблица 2.

Формат сжатия | Операционная система MS DOS |  | Операционная система Windows
 | Программа архивации | Программа разархивации | Программа архивации | Программа разархивации
ARJ | Arj.exe | Arj.exe | WinArj.exe | WinArj.exe
RAR | Rar.exe | Unrar.exe | WinRar.exe | WinRar.exe
ZIP | Pkzip.exe | Pkunzip.exe | WinZip.exe | WinZip.exe

Кроме того, современные архиваторы предоставляют пользователю полный спектр услуг для работы с архивами, основными из которых являются:

  1. создание нового архива;
  2. добавление файлов в существующий архив;
  3. распаковывание файлов из архива;
  4. создание самораспаковающихся архивов (self-extractor archive);
  5. создание распределенных архивов фиксированного размера для носителей маленькой емкости;
  6. защита архивов паролями от несанкционированного доступа;
  7. просмотр содержимого файлов разных форматов без предварительного распаковывания;
  8. поиск файлов и данных внутри архива;
  9. проверка на вирусы в архиве к распаковыванию;
  10. выбор и настройка коэффициента сжатия.

Контрольные вопросы

1. Какие факторы влияют на степень избыточности данных?
2. Что такое архив? Какие программные средства называются архиваторами?
3. Почему методы сжатия, при которых происходит изменение содержимого данных, называются необратимыми?
4. Приведите примеры форматов сжатия с потерями информации.
5. В чем состоит преимущество обратимых методов сжатия над необратимыми? А недостаток?
6. Которая существует зависимость между коэффициентом сжатия и эффективностью метода сжатия?
7. В чем состоит основная идея алгоритма RLE?
8. В чем состоит основная идея алгоритмов группы KWE?
9. В чем состоит основная идея алгоритма Хаффмана?
10. Какие вы знаете програми-архиваторы? Коротко охарактеризуйте их.

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"


Лекция 10 "Компьютерные вирусы"

Компьютерный вирус - это небольшая программа, написанная программистом высокой квалификации, способная к саморазмножению и выполнению разных деструктивных действий. На сегодняшний день известно свыше 50 тыс. компьютерных вирусов.

Существует много разных версий относительно даты рождения первого компьютерного вируса. Однако большинство специалистов сходятся на мысли, что компьютерные вирусы, как таковые, впервые появились в 1986 году, хотя исторически возникновение вирусов тесно связано с идеей создания самовоспроизводящихся программ. Одним из "пионеров" среди компьютерных вирусов считается вирус "Brain", созданный пакистанским программистом по фамилии Алви. Только в США этот вирус поразил свыше 18 тыс. компьютеров. В начале эпохи компьютерных вирусов разработка вирусоподобных программ носила чисто исследовательский характер, постепенно превращаясь на откровенно вражеское отношение к пользователям безответственных, и даже криминальных "элементов". В ряде стран уголовное законодательство предусматривает ответственность за компьютерные преступления, в том числе за создание и распространение вирусов.

Вирусы действуют только программным путем. Они, как правило, присоединяются к файлу или проникают в тело файла. В этом случае говорят, что файл заражен вирусом. Вирус попадает в компьютер только вместе с зараженным файлом. Для активизации вируса нужно загрузить зараженный файл, и только после этого, вирус начинает действовать самостоятельно.

Некоторые вирусы во время запуска зараженного файла становятся резидентными (постоянно находятся в оперативной памяти компьютера) и могут заражать другие загружаемые файлы и программы. Другая разновидность вирусов сразу после активизации может быть причиной серьезных повреждений, например, форматировать жесткий диск. Действие вирусов может проявляться по разному: от разных визуальных эффектов, мешающих работать, до полной потери информации. Большинство вирусов заражают исполнительные программы, то есть файлы с расширением .EXE и .COM, хотя в последнее время большую популярность приобретают вирусы, распространяемые через систему электронной почты.

Следует заметить, что компьютерные вирусы способны заражать лишь компьютеры. Поэтому абсолютно абсурдными являются разные утверждения о влиянии компьютерных вирусов на пользователей компьютеров.

Основные источники вирусов:

  • дискета, на которой находятся зараженные вирусом файлы;
  • компьютерная сеть, в том числе система электронной почты и Internet;
  • жесткий диск, на который попал вирус в результате работы с зараженными программами;
  • вирус, оставшийся в оперативной памяти после предшествующего пользователя.

Основные ранние признаки заражения компьютера вирусом:

  • уменьшение объема свободной оперативной памяти;
  • замедление загрузки и работы компьютера;
  • непонятные (без причин) изменения в файлах, а также изменения размеров и даты последней модификации файлов;
  • ошибки при загрузке операционной системы;
  • невозможность сохранять файлы в нужных каталогах;
  • непонятные системные сообщения, музыкальные и визуальные эффекты и т.д.

Признаки активной фазы вируса:

  • исчезновение файлов;
  • форматирование жесткого диска;
  • невозможность загрузки файлов или операционной системы.

Существует очень много разных вирусов. Условно их можно классифицировать следующим образом:

1) загрузочные вирусы или BOOT-вирусы заражают boot-секторы дисков. Очень опасные, могут привести к полной потере всей информации, хранящейся на диске;

2) файловые вирусы заражают файлы. Делятся на:

  • вирусы, заражающие программы (файлы с расширением .EXE и .COM);
  • макровирусы вирусы, заражающие файлы данных, например, документы Word или рабочие книги Excel;
  • вирусы-спутники используют имена других файлов;
  • вирусы семейства DIR искажают системную информацию о файловых структурах;

3) загрузочно-файловые вирусы способные поражать как код boot-секторов, так и код файлов;

4) вирусы-невидимки или STEALTH-вирусы фальсифицируют информацию прочитанную из диска так, что программа, какой предназначена эта информация получает неверные данные. Эта технология, которую, иногда, так и называют Stealth-технологией, может использоваться как в BOOT-вирусах, так и в файловых вирусах;

5) ретровирусы заражают антивирусные программы, стараясь уничтожить их или сделать нетрудоспособными;

6) вирусы-черви снабжают небольшие сообщения электронной почты, так называемым заголовком, который по своей сути есть Web-адресом местонахождения самого вируса. При попытке прочитать такое сообщение вирус начинает считывать через глобальную сеть Internet свое 'тело' и после загрузки начинает деструктивное действие. Очень опасные, так как обнаружить их очень тяжело, в связи с тем, что зараженный файл фактически не содержит кода вируса.

Если не принимать меры для защиты от компьютерных вирусов, то следствия заражения могут быть очень серьезными. В ряде стран уголовное законодательство предусматривает ответственность за компьютерные преступления, в том числе за внедрение вирусов. Для защиты информации от вирусов используются общие и программные средства.

К общим средствам, помогающим предотвратить заражение и его разрушительных последствий относят:

  • резервное копирование информации (создание копий файлов и системных областей жестких дисков);
  • избежание пользования случайными и неизвестными программами. Чаще всего вирусы распространяются вместе с компьютерными программами;
  • перезагрузка компьютера перед началом работы, в частности, в случае, если за этим компьютером работали другие пользователи;
  • ограничение доступа к информации, в частности физическая защита дискеты во время копирования файлов с нее.

К программным средствам защиты относят разные антивирусные программы (антивирусы). Антивирус - это программа, выявляющая и обезвреживающая компьютерные вирусы. Следует заметить, что вирусы в своем развитии опережают антивирусные программы, поэтому даже в случае регулярного пользования антивирусов, нет 100% гарантии безопасности. Антивирусные программы могут выявлять и уничтожать лишь известные вирусы, при появлении нового компьютерного вируса защиты от него не существует до тех пор, пока для него не будет разработан свой антивирус. Однако, много современных антивирусных пакетов имеют в своем составе специальный программный модуль, называемый эвристическим анализатором, который способен исследовать содержимое файлов на наличие кода, характерного для компьютерных вирусов. Это дает возможность своевременно выявлять и предупреждать об опасности заражения новым вирусом.

Различают такие типы антивирусных программ:

1) программы-детекторы: предназначены для нахождения зараженных файлов одним из известных вирусов. Некоторые программы-детекторы могут также лечить файлы от вирусов или уничтожать зараженные файлы. Существуют специализированные, то есть предназначенные для борьбы с одним вирусом детекторы и полифаги, которые могут бороться с многими вирусами;

2) программы-лекари: предназначены для лечения зараженных дисков и программ. Лечение программы состоит в изъятии из зараженной программы тела вируса. Также могут быть как полифагами, так и специализированными;

3) программы-ревизоры: предназначены для выявления заражения вирусом файлов, а также нахождение поврежденных файлов. Эти программы запоминают данные о состоянии программы и системных областей дисков в нормальном состоянии (до заражения) и сравнивают эти данные в процессе работы компьютера. В случае несоответствия данных выводится сообщение о возможности заражения;

4) лекари-ревизоры: предназначены для выявления изменений в файлах и системных областях дисков и, в случае изменений, возвращают их в начальное состояние.

5) программы-фильтры: предназначены для перехвата обращений к операционной системе, которые используются вирусами для размножения и сообщают об этом пользователя. Пользователь может разрешить или запретить выполнение соответствующей операции. Такие программы являются резидентными, то есть они находятся в оперативной памяти компьютера.

6) программы-вакцины: используются для обработки файлов и boot-секторов с целью предупреждения заражения известными вирусами (в последнее время этот метод используется все чаще).

Следует заметить, что выбор одного "наилучшего" антивируса крайне ошибочное решение. Рекомендуется использовать несколько разных антивирусных пакетов одновременно. Выбирая антивирусную программу следует обратить внимание на такой параметр, как количество распознающих сигнатур (последовательность символов, которые гарантированно распознают вирус). Второй параметр - наличие эвристического анализатора неизвестных вирусов, его присутствие очень полезно, но существенно замедляет время работы программы. На сегодняшний день существует большое количество разнообразных антивирусных программ. Рассмотрим коротко, распространенные в странах СНГ.

DRWEB

Один из лучших антивирусов с мощным алгоритмом нахождения вирусов. Полифаг, способный проверять файлы в архивах, документы Word и рабочие книги Excel, выявляет полиморфные вирусы, которые в последнее время, получают все большее распространение. Достаточно сказать, что эпидемию очень опасного вируса OneHalf остановил именно DrWeb. Эвристический анализатор DrWeb, исследуя программы на наличие фрагментов кода, характерных для вирусов, разрешает найти почти 90% неизвестных вирусов. При загрузке программы, в первую очередь DrWeb проверяет самого себя на целостность, после чего тестирует оперативную память. Программа может работать в диалоговом режиме, имеет удобный настраиваемый интерфейс пользователя.

ADINF

Антивирус-ревизор диска ADINF (Avanced DiskINFoscope) разрешает находить и уничтожать, как существующие обычные, stealth- и полиморфные вирусы, так и совсем новые. Антивирус имеет в своем распоряжении лечащий блок ревизора ADINF - Adinf Cure Module - что может обезвредить до 97% всех вирусов. Эту цифру приводит "Диалогнаука", исходя из результатов тестирования, которое происходило на коллекциях вирусов двух признанных авторитетов в этой области - Д.Н.Лозинского и фирмы Dr.Sоlомоn's (Великобритания).

ADINF загружается автоматически в случае включения компьютера и контролирует boot-сектор и файлы на диске (дата и время создания, длина, контрольная сумма), выводя сообщения про их изменения. Благодаря тому, что ADINF осуществляет дисковые операции в обход операционной системы, обращаясь к функциям BIOS, достигаются не только возможность выявления активных stеаlth-вірусів, но и высокая скорость проверки диска. Если найден boot-вирус, то ADINF просто восстановит предшествующий загрузочный сектор, который хранится в его таблице. Если вирус файловый, то здесь на помощь приходит лечащий блок Adinf Cure Module, который на основе отчета основного модуля о зараженных файлах сравнивает новые параметры файлов с предыдущими, хранящиеся в специальных таблицах. При выявлении расхождений ADINF восстанавливает предыдущее состояние файла, а не уничтожает тело вируса, как это делают полифаги.

AVP

Антивирус AVP (AntiVirus Program) относится к полифагам, в процессе работы проверяет оперативную память, файлы, в том числе архивные, на гибких, локальных, сетевых и CD-ROM дисках, а также системные структуры данных, такие как загрузочный сектор, таблицу разделов и т.д. Программа имеет эвристический анализатор, который, по утверждениям разработчиков антивируса способен находить почти 80% всех вирусов. Программа AVP является 32-разрядным приложением для работы в среде операционных систем Windows 98, NT и 2000, имеет удобный интерфейс, а также одну из самых больших в мире антивирусную базу. Базы антивирусов к AVP обновляются приблизительно один раз в неделю и их можно получить с Internеt. Эта программа осуществляет поиск и изъятие разнообразнейших вирусов, в том числе:

  • полиморфных, или самошифрующихся вирусов;
  • стелс-вирусов, или вирусов-невидимок;
  • новых вирусов для Windows;
  • макровирусов, заражающих документы Word и таблицы Excel.

Кроме того, программа AVP осуществляет контроль файловых операций в системе в фоновом режиме, выявляет вирус до момента реального заражения системы, а также определяет неизвестные вирусы с помощью эвристического модуля.

Контрольные вопросы

  1. Что такое компьютерный вирус?
  2. Каким образом вирус заражает компьютер?
  3. Каким образом действуют компьютерные вирусы?
  4. Какие вы знаете источники заражения компьютерным вирусом?
  5. По каким признакам можно обнаружить факт заражения компьютерным вирусом?
  6. Какие вы знаете типы вирусов? Какие деструктивные действия они осуществляют?
  7. Какие действия предпринимают для предотвращения заражения компьютерным вирусом?
  8. Что такое антивирус? Какие типы антивирусов вы знаете?
  9. Что такое эвристический анализатор? Какие функции он выполняет?
  10. Приведите примеры антивирусных программ. Коротко охарактеризуйте их.

Список рекомендованной литературы

  1. Информатика. Базовый курс. / Под ред. С.В.Симоновича. - СПб., 2000 г.
  2. А.П.Микляев, Настольная книга пользователя IBM PC 3-издание М.:, "Солон-Р", 2000, 720 с.
  3. Симонович С.В., Евсеев Г.А., Мураховский В.И. Вы купили компьютер: Полное руководство для начинающих в вопросах и ответах. - М.: АСТ-ПРЕСС КНИГА; Инфорком-Пресс, 2001.- 544 с.: ил. (1000 советов).
  4. Ковтанюк Ю.С., Соловьян С.В. Самоучитель работы на персональном компьютере - К.:Юниор, 2001.- 560с., ил.

Другие лекции

Лекция 1" Предмет и основные понятия информатики"
Лекция 2 "Системы исчисления"
Лекция 3 "Архитектура вычислительной системы. Классификация компьютеров"
Лекция 4 "Персональный компьютер: системная плата"
Лекция 5 "Персональный компьютер: внешняя память"
Лекция 6 "Персональный компьютер: стандартные устройства ввода-вывода"
Лекция 7 "Персональный компьютер: периферийные устройства ввода-вывода"
Лекция 8 " Программное обеспечение"